# CVE-2020-35928: Data races in concread

> Attackers can trigger a data race in the ARCache structure by sending non-Send/Sync types, potentially causing denial of service.

- **Severity:** Medium 4.7 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Dec 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-4xj5-vv9x-63jp, RUSTSEC-2020-0092

## What is CVE-2020-35928?

CVE-2020-35928 is a medium-severity vulnerability in n/a, published on 31 Dec 2020. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

An issue was discovered in the concread crate before 0.2.6 for Rust. Attackers can cause an ARCache<K,V> data race by sending types that do not implement Send/Sync.

Weakness: CWE-362 (Concurrent Execution using Shared Resource with Improper Synchronization)

## Which versions are affected by CVE-2020-35928?

3 open source packages ship an affected version, including concread. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `concread` | crates.io | All versions | 0.2.6 |
| `concread` | crates.io | All versions | 0.2.6 |
| `concread` | crates.io | From 0.0.0-0 | 0.2.6 |

Products: Concread Project Concread.

## How do I fix CVE-2020-35928?

Upgrade concread to 0.2.6 or later.

## Is CVE-2020-35928 being exploited?

There is no known exploitation of CVE-2020-35928 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-35928 and fix it if it is affected.

What it is: CVE-2020-35928 is a medium-severity vulnerability in n/a, published on 31 Dec 2020. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-35928 in the wild and no public exploit code.

Affected packages and fixed versions:
- concread (crates.io): affected all versions; fixed in 0.2.6
- concread (crates.io): affected all versions; fixed in 0.2.6
- concread (crates.io): affected from 0.0.0-0; fixed in 0.2.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-35928/ (Markdown: https://insights.sbomify.com/CVE-2020-35928/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-35928
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-35928
- OSV: https://osv.dev/vulnerability/CVE-2020-35928

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-35928/
Summaries are generated and may contain mistakes; the official description above is the record.
