{"answers":{"affected":"1 open source package ship an affected version, including fluent-bit. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-35963 in the wild and no public exploit code.","fix":"Upgrade fluent-bit to 1.6.4 or later.","what":"CVE-2020-35963 is a high-severity memory corruption vulnerability in n/a, published on 3 Jan 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-35963 and fix it if it is affected.\n\nWhat it is: CVE-2020-35963 is a high-severity memory corruption vulnerability in n/a, published on 3 Jan 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-35963 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- fluent-bit (Bitnami): affected all versions; fixed in 1.6.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-35963/ (Markdown: https://insights.sbomify.com/CVE-2020-35963/index.md)","id":"CVE-2020-35963","markdown":"https://insights.sbomify.com/CVE-2020-35963/index.md","name":"CVE-2020-35963","record":{"aliases":["BIT-fluent-bit-2020-35963","GHSA-h5px-998j-r7c9"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Fluent Bit log processor","requires_auth":"none","summary":"An out-of-bounds write in Fluent Bit's gzip compression allows attackers to execute arbitrary code or cause a denial of service.","user_interaction":"required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"fluent_bit","vendor":"treasuredata"}],"cvss":{"score":7.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"}],"description":"flb_gzip_compress in flb_gzip.c in Fluent Bit before 1.6.4 has an out-of-bounds write because it does not use the correct calculation of the maximum gzip data-size expansion.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Memory corruption in n/a","id":"CVE-2020-35963","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"memory_corruption","year":"2020"},"n_packages":1,"n_references":3,"next":{"headline":"Memory corruption in n/a","id":"CVE-2020-35964"},"packages":[{"ecosystem":"Bitnami","fixed":["1.6.4"],"introduced":["0"],"last_affected":[],"package":"fluent-bit","purl":"pkg:bitnami/fluent-bit","source":"BIT-fluent-bit-2020-35963"}],"prev":{"headline":"Missing authorization in n/a","id":"CVE-2020-35962"},"products":["n/a"],"published":"2021-01-03","related":[{"cvss_score":9.8,"headline":"Fluent Bit Memory Corruption Vulnerability","id":"CVE-2024-4323","kev_date_added":null,"published":"2024-05-20"},{"cvss_score":9.8,"headline":"Use after free in n/a","id":"CVE-2021-36088","kev_date_added":null,"published":"2021-07-01"},{"cvss_score":9.1,"headline":"CVE-2025-12977","id":"CVE-2025-12977","kev_date_added":null,"published":"2025-11-24"},{"cvss_score":8.8,"headline":"CVE-2025-12970","id":"CVE-2025-12970","kev_date_added":null,"published":"2025-11-24"},{"cvss_score":7.8,"headline":"Use after free in n/a","id":"CVE-2021-46878","kev_date_added":null,"published":"2023-04-11"},{"cvss_score":7.8,"headline":"Memory corruption in n/a","id":"CVE-2021-46879","kev_date_added":null,"published":"2023-04-11"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"An out-of-bounds write in Fluent Bit's gzip compression allows attackers to execute arbitrary code or cause a denial of service.","url":"https://insights.sbomify.com/CVE-2020-35963/"}