CVE-2020-36049 Resource exhaustion in socket.io-parser
Attackers can cause denial of service via memory consumption by sending large packets to the socket.io-parser library.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-36049?
CVE-2020-36049 is a high-severity denial of service vulnerability in n/a, published on 7 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
socket.io-parser before 3.4.1 allows attackers to cause a denial of service (memory consumption) via a large packet because a concatenation approach is used.
Weakness: CWE-770
Which versions are affected by CVE-2020-36049?
4 open source packages ship an affected version, including socket.io-parser. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
socket.io-parser npm | All versions | 3.3.2 |
socket.io-parser npm | All versions | 3.3.2 |
socket.io-parser npm | From 3.4.0 | 3.4.1 |
socket.io-parser npm | From 3.4.0 | 3.4.1 |
Products include Socket Socket.io-Parser.
How do I fix CVE-2020-36049?
Upgrade socket.io-parser to a fixed version for your release line: 3.3.2 or 3.4.1.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2020-36049 being exploited?
There is no known exploitation of CVE-2020-36049 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as AZL-45030, DEBIAN-CVE-2020-36049, GHSA-xfhh-g9f5-x4m4, UBUNTU-CVE-2020-36049.