CVE-2020-36067 Improper Validation of Array Index in GJSON

High 7.5 Published Updated

Attackers can cause a denial of service via a crafted GET call in the GJSON Go library, requiring an upgrade to mitigate.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2020-36067?

CVE-2020-36067 is a high-severity denial of service vulnerability in n/a, published on 5 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

GJSON <=v1.6.5 allows attackers to cause a denial of service (panic: runtime error: slice bounds out of range) via a crafted GET call.

Weakness: CWE-129

Which versions are affected by CVE-2020-36067?

3 open source packages ship an affected version, including github.com/tidwall/gjson. It affects 1 product.

PackageAffectedFixed in
github.com/tidwall/gjson GoAll versions1.6.6
github.com/tidwall/gjson GoAll versions1.6.6
github.com/tidwall/gjson GoAll versions1.6.6

Products include Gjson Project Gjson.

How do I fix CVE-2020-36067?

Upgrade github.com/tidwall/gjson to 1.6.6 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2020-36067 being exploited?

There is no known exploitation of CVE-2020-36067 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2020-36067, GHSA-p64j-r5f4-pwwx, GO-2021-0054, UBUNTU-CVE-2020-36067.

Is CVE-2020-36067 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free