CVE-2020-36190 rails_admin ruby gem XSS vulnerability
Cross-site scripting vulnerability in RailsAdmin allows attackers to inject malicious scripts via nested forms, potentially leading to session hijacking or code execution.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2020-36190?
CVE-2020-36190 is a medium-severity cross-site scripting vulnerability in n/a, published on 12 Jan 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
RailsAdmin (aka rails_admin) before 1.4.3 and 2.x before 2.0.2 allows XSS via nested forms.
Weakness: CWE-79
Which versions are affected by CVE-2020-36190?
4 open source packages ship an affected version, including rails_admin. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
rails_admin RubyGems | All versions | 1.4.3 |
rails_admin RubyGems | All versions | 1.4.3 |
rails_admin RubyGems | From 2.0.0 | 2.0.2 |
rails_admin RubyGems | From 2.0.0 | 2.0.2 |
Products include Rails Admin Project Rails Admin.
How do I fix CVE-2020-36190?
Upgrade rails_admin to a fixed version for your release line: 1.4.3 or 2.0.2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2020-36190 being exploited?
There is no known exploitation of CVE-2020-36190 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as GHSA-wjx2-7hqq-8h7m.