{"answers":{"affected":"4 open source packages ship an affected version, including rails_admin. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-36190 in the wild and no public exploit code.","fix":"Upgrade rails_admin to a fixed version for your release line: 1.4.3 or 2.0.2.","what":"CVE-2020-36190 is a medium-severity cross-site scripting vulnerability in n/a, published on 12 Jan 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-36190 and fix it if it is affected.\n\nWhat it is: CVE-2020-36190 is a medium-severity cross-site scripting vulnerability in n/a, published on 12 Jan 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-36190 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- rails_admin (RubyGems): affected all versions; fixed in 1.4.3\n- rails_admin (RubyGems): affected all versions; fixed in 1.4.3\n- rails_admin (RubyGems): affected from 2.0.0; fixed in 2.0.2\n- rails_admin (RubyGems): affected from 2.0.0; fixed in 2.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-36190/ (Markdown: https://insights.sbomify.com/CVE-2020-36190/index.md)","id":"CVE-2020-36190","markdown":"https://insights.sbomify.com/CVE-2020-36190/index.md","name":"CVE-2020-36190","record":{"aliases":["GHSA-wjx2-7hqq-8h7m"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"RailsAdmin Ruby gem","requires_auth":"none","summary":"Cross-site scripting vulnerability in RailsAdmin allows attackers to inject malicious scripts via nested forms, potentially leading to session hijacking or code execution.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"rails_admin","vendor":"rails_admin_project"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"RailsAdmin (aka rails_admin) before 1.4.3 and 2.x before 2.0.2 allows XSS via nested forms.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"rails_admin ruby gem XSS vulnerability","id":"CVE-2020-36190","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"xss","year":"2020"},"n_packages":4,"n_references":3,"next":{"headline":"Cross-Site Request Forgery in JupyterHub","id":"CVE-2020-36191"},"packages":[{"ecosystem":"RubyGems","fixed":["1.4.3"],"introduced":["0"],"last_affected":[],"package":"rails_admin","purl":null,"source":"GHSA-wjx2-7hqq-8h7m"},{"ecosystem":"RubyGems","fixed":["1.4.3"],"introduced":["0"],"last_affected":[],"package":"rails_admin","purl":"pkg:gem/rails_admin","source":"GHSA-wjx2-7hqq-8h7m"},{"ecosystem":"RubyGems","fixed":["2.0.2"],"introduced":["2.0.0"],"last_affected":[],"package":"rails_admin","purl":null,"source":"GHSA-wjx2-7hqq-8h7m"},{"ecosystem":"RubyGems","fixed":["2.0.2"],"introduced":["2.0.0"],"last_affected":[],"package":"rails_admin","purl":"pkg:gem/rails_admin","source":"GHSA-wjx2-7hqq-8h7m"}],"prev":{"headline":"Unsafe Deserialization in jackson-databind","id":"CVE-2020-36189"},"products":["n/a"],"published":"2021-01-12","related":[{"cvss_score":8.8,"headline":"Cross-site request forgery in rails_admin","id":"CVE-2016-10522","kev_date_added":null,"published":"2018-07-05"},{"cvss_score":6.8,"headline":"RailsAdmin Cross-site Scripting vulnerability in the list view","id":"CVE-2024-39308","kev_date_added":null,"published":"2024-07-08"},{"cvss_score":6.1,"headline":"rails_admin ruby gem XSS","id":"CVE-2017-12098","kev_date_added":null,"published":"2018-01-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Cross-site scripting vulnerability in RailsAdmin allows attackers to inject malicious scripts via nested forms, potentially leading to session hijacking or code execution.","url":"https://insights.sbomify.com/CVE-2020-36190/"}