# CVE-2020-36193: PEAR Archive_Tar Improper Link Resolution

> Attackers can exploit inadequate symbolic link checks in the Archive_Tar library to perform directory traversal and write files to arbitrary locations.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Yes, since 25 Aug 2022 (CISA KEV)
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Jan 2021
- **Updated:** 21 Oct 2025
- **Also known as:** BIT-drupal-2020-36193, CLEANSTART-2024-DI03393, DEBIAN-CVE-2020-36193, DLA-2530-1, DLA-2621-1, DSA-4894-1, GHSA-rpw6-9xfx-jvcx, MGASA-2021-0060, SUSE-SU-2021:2926-1, SUSE-SU-2021:3006-1, SUSE-SU-2021:3018-1, UBUNTU-CVE-2020-36193, USN-4723-1, openSUSE-SU-2021:1267-1, openSUSE-SU-2021:2872-1, openSUSE-SU-2021:3018-1

## What is CVE-2020-36193?

CVE-2020-36193 is a high-severity path traversal vulnerability in Debian Debian Linux, published on 18 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Tar.php in Archive_Tar through 1.4.11 allows write operations with Directory Traversal due to inadequate checking of symbolic links, a related issue to CVE-2020-28948.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory), CWE-59 (Improper Link Resolution Before File Access)

## Which versions are affected by CVE-2020-36193?

3 open source packages ship an affected version, including pear/archive_tar and drupal. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pear/archive_tar` | Packagist | All versions | 1.4.13 |
| `pear/archive_tar` | Packagist | All versions | 1.4.13 |
| `drupal` | Bitnami | From 7.0.0 | 7.78.0, 8.9.13, 9.0.11, 9.1.3 |
| `php72` | SUSE:Linux Enterprise Module for Web and Scripting 12 | All versions | 7.2.5-1.69.1 |
| `php74-pear` | SUSE:Linux Enterprise Module for Web and Scripting 12 | All versions | 1.10.21-1.6.1 |
| `php7-pear` | SUSE:Linux Enterprise Module for Web and Scripting 15 SP2 | All versions | 1.10.21-3.6.1 |
| `php7-pear` | SUSE:Linux Enterprise Module for Web and Scripting 15 SP3 | All versions | 1.10.21-3.6.1 |
| `php72` | SUSE:Linux Enterprise Software Development Kit 12 SP5 | All versions | 7.2.5-1.69.1 |
| `php7-pear` | openSUSE:Leap 15.2 | All versions | 1.10.21-lp152.2.6.1 |
| `php7` | openSUSE:Leap 15.3 | All versions | 7.2.5-4.82.1 |
| `php7-pear` | openSUSE:Leap 15.3 | All versions | 1.10.21-3.6.1 |

Products: Debian Debian Linux, Drupal Drupal, Fedoraproject Fedora, Php Archive Tar.

## How do I fix CVE-2020-36193?

Upgrade pear/archive_tar to 1.4.13 or later. US federal agencies must fix it by 15 Sep 2022.

## Is CVE-2020-36193 being exploited?

Yes. Attackers have exploited CVE-2020-36193 in the wild since at least 25 Aug 2022.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-36193 and fix it if it is affected.

What it is: CVE-2020-36193 is a high-severity path traversal vulnerability in Debian Debian Linux, published on 18 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2020-36193 in the wild since at least 25 Aug 2022.

Affected packages and fixed versions:
- pear/archive_tar (Packagist): affected all versions; fixed in 1.4.13
- pear/archive_tar (Packagist): affected all versions; fixed in 1.4.13
- drupal (Bitnami): affected from 7.0.0; fixed in 7.78.0, 8.9.13, 9.0.11, 9.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-36193/ (Markdown: https://insights.sbomify.com/CVE-2020-36193/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-36193
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-36193
- OSV: https://osv.dev/vulnerability/CVE-2020-36193

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-36193/
Summaries are generated and may contain mistakes; the official description above is the record.
