# CVE-2020-36204: Data races in im

> A data race in the Rust im crate's TreeFocus allows concurrent access issues due to missing Send/Sync bounds, potentially causing undefined behavior.

- **Severity:** Medium 4.7 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jan 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-q9h2-4xhf-23xx, RUSTSEC-2020-0096

## What is CVE-2020-36204?

CVE-2020-36204 is a medium-severity vulnerability in n/a, published on 22 Jan 2021. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

An issue was discovered in the im crate through 2020-11-09 for Rust. Because TreeFocus does not have bounds on its Send trait or Sync trait, a data race can occur.

## Which versions are affected by CVE-2020-36204?

3 open source packages ship an affected version, including im. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `im` | crates.io | From 12.0.0 | 15.1.0 |
| `im` | crates.io | From 12.0.0 | 15.1.0 |
| `im` | crates.io | From 12.0.0 | 15.1.0 |

Products: Im Project Im.

## How do I fix CVE-2020-36204?

Upgrade im to 15.1.0 or later.

## Is CVE-2020-36204 being exploited?

There is no known exploitation of CVE-2020-36204 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-36204 and fix it if it is affected.

What it is: CVE-2020-36204 is a medium-severity vulnerability in n/a, published on 22 Jan 2021. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-36204 in the wild and no public exploit code.

Affected packages and fixed versions:
- im (crates.io): affected from 12.0.0; fixed in 15.1.0
- im (crates.io): affected from 12.0.0; fixed in 15.1.0
- im (crates.io): affected from 12.0.0; fixed in 15.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-36204/ (Markdown: https://insights.sbomify.com/CVE-2020-36204/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-36204
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-36204
- OSV: https://osv.dev/vulnerability/CVE-2020-36204

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-36204/
Summaries are generated and may contain mistakes; the official description above is the record.
