# CVE-2020-36205: Memory handling issues in xcb

> A use-after-free or double-free vulnerability in the Rust xcb crate allows attackers to potentially execute arbitrary code or cause a denial of service.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jan 2021
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2020-36205, GHSA-c8hq-x4mm-p6q6, RUSTSEC-2020-0097, UBUNTU-CVE-2020-36205

## What is CVE-2020-36205?

CVE-2020-36205 is a medium-severity use after free vulnerability in n/a, published on 22 Jan 2021. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

An issue was discovered in the xcb crate through 2020-12-10 for Rust. base::Error does not have soundness. Because of the public ptr field, a use-after-free or double-free can occur.

Weakness: CWE-416 (Use After Free), CWE-415 (Double Free)

## Which versions are affected by CVE-2020-36205?

3 open source packages ship an affected version, including xcb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `xcb` | crates.io | All versions | 1.0.0 |
| `xcb` | crates.io | All versions | 1.0.0 |
| `xcb` | crates.io | From 0.0.0-0 | 1.0.0 |

Products: Xcb Project Xcb.

## How do I fix CVE-2020-36205?

Upgrade xcb to 1.0.0 or later.

## Is CVE-2020-36205 being exploited?

There is no known exploitation of CVE-2020-36205 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-26955](https://insights.sbomify.com/CVE-2021-26955/): Memory corruption in n/a (critical 9.8)
- [CVE-2021-26956](https://insights.sbomify.com/CVE-2021-26956/): Memory corruption in n/a (critical 9.8)
- [CVE-2021-26957](https://insights.sbomify.com/CVE-2021-26957/): Memory corruption in n/a (critical 9.8)
- [CVE-2021-26958](https://insights.sbomify.com/CVE-2021-26958/): Memory corruption in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-36205 and fix it if it is affected.

What it is: CVE-2020-36205 is a medium-severity use after free vulnerability in n/a, published on 22 Jan 2021. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-36205 in the wild and no public exploit code.

Affected packages and fixed versions:
- xcb (crates.io): affected all versions; fixed in 1.0.0
- xcb (crates.io): affected all versions; fixed in 1.0.0
- xcb (crates.io): affected from 0.0.0-0; fixed in 1.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-36205/ (Markdown: https://insights.sbomify.com/CVE-2020-36205/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-36205
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-36205
- OSV: https://osv.dev/vulnerability/CVE-2020-36205

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-36205/
Summaries are generated and may contain mistakes; the official description above is the record.
