# CVE-2020-36206: Data races in rusb

> A data race in the rusb crate can lead to memory corruption, allowing attackers to execute arbitrary code or cause denial of service.

- **Severity:** High 7.0 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jan 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-9mxw-4856-9cm5, RUSTSEC-2020-0098

## What is CVE-2020-36206?

CVE-2020-36206 is a high-severity vulnerability in n/a, published on 22 Jan 2021. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

An issue was discovered in the rusb crate before 0.7.0 for Rust. Because of a lack of Send and Sync bounds, a data race and memory corruption can occur.

Weakness: CWE-787 (Out-of-bounds Write), CWE-662 (Improper Synchronization)

## Which versions are affected by CVE-2020-36206?

3 open source packages ship an affected version, including rusb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rusb` | crates.io | All versions | 0.7.0 |
| `rusb` | crates.io | All versions | 0.7.0 |
| `rusb` | crates.io | From 0.0.0-0 | 0.7.0 |

Products: Rusb Project Rusb.

## How do I fix CVE-2020-36206?

Upgrade rusb to 0.7.0 or later.

## Is CVE-2020-36206 being exploited?

There is no known exploitation of CVE-2020-36206 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-36206 and fix it if it is affected.

What it is: CVE-2020-36206 is a high-severity vulnerability in n/a, published on 22 Jan 2021. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-36206 in the wild and no public exploit code.

Affected packages and fixed versions:
- rusb (crates.io): affected all versions; fixed in 0.7.0
- rusb (crates.io): affected all versions; fixed in 0.7.0
- rusb (crates.io): affected from 0.0.0-0; fixed in 0.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-36206/ (Markdown: https://insights.sbomify.com/CVE-2020-36206/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-36206
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-36206
- OSV: https://osv.dev/vulnerability/CVE-2020-36206

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-36206/
Summaries are generated and may contain mistakes; the official description above is the record.
