CVE-2020-36209 Data races in late-static
High 7.0
Published
Updated
Check this codebase for CVE-2020-36209 and fix it if it is affected.
What it is: CVE-2020-36209 is a high-severity vulnerability in n/a, published on 22 Jan 2021.
Exploitation: There is no known exploitation of CVE-2020-36209 in the wild and no public exploit code.
Affected packages and fixed versions:
- late-static (crates.io): affected all versions; fixed in 0.4.0
- late-static (crates.io): affected all versions; fixed in 0.4.0
- late-static (crates.io): affected from 0.0.0-0; fixed in 0.4.0
Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.
Reference: https://insights.sbomify.com/CVE-2020-36209/ (Markdown: https://insights.sbomify.com/CVE-2020-36209/index.md)
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2020-36209?
CVE-2020-36209 is a high-severity vulnerability in n/a, published on 22 Jan 2021.
Official description
An issue was discovered in the late-static crate before 0.4.0 for Rust. Because Sync is implemented for LateStatic with T: Send, a data race can occur.
Which versions are affected by CVE-2020-36209?
3 open source packages ship an affected version, including late-static. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
late-static crates.io | All versions | 0.4.0 |
late-static crates.io | All versions | 0.4.0 |
late-static crates.io | From 0.0.0-0 | 0.4.0 |
Products include Late-Static Project Late-Static.
How do I fix CVE-2020-36209?
Upgrade late-static to 0.4.0 or later.
Is CVE-2020-36209 being exploited?
There is no known exploitation of CVE-2020-36209 in the wild and no public exploit code.
Sources
Also known as GHSA-wr55-mf5c-hhwm, RUSTSEC-2020-0102.