# CVE-2020-36214: Data races in multiqueue2

> A data race in the multiqueue2 Rust crate allows non-Send types to cross thread boundaries, potentially causing undefined behavior.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jan 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-jphw-p3m6-pj3c, RUSTSEC-2020-0106

## What is CVE-2020-36214?

CVE-2020-36214 is a medium-severity vulnerability in n/a, published on 22 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the multiqueue2 crate before 0.1.7 for Rust. Because a non-Send type can be sent to a different thread, a data race can occur.

## Which versions are affected by CVE-2020-36214?

3 open source packages ship an affected version, including multiqueue2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `multiqueue2` | crates.io | All versions | 0.1.7 |
| `multiqueue2` | crates.io | All versions | 0.1.7 |
| `multiqueue2` | crates.io | From 0.0.0-0 | 0.1.7 |

Products: Multiqueue2 Project Multiqueue2.

## How do I fix CVE-2020-36214?

Upgrade multiqueue2 to 0.1.7 or later.

## Is CVE-2020-36214 being exploited?

There is no known exploitation of CVE-2020-36214 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-36214 and fix it if it is affected.

What it is: CVE-2020-36214 is a medium-severity vulnerability in n/a, published on 22 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-36214 in the wild and no public exploit code.

Affected packages and fixed versions:
- multiqueue2 (crates.io): affected all versions; fixed in 0.1.7
- multiqueue2 (crates.io): affected all versions; fixed in 0.1.7
- multiqueue2 (crates.io): affected from 0.0.0-0; fixed in 0.1.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-36214/ (Markdown: https://insights.sbomify.com/CVE-2020-36214/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-36214
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-36214
- OSV: https://osv.dev/vulnerability/CVE-2020-36214

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-36214/
Summaries are generated and may contain mistakes; the official description above is the record.
