# CVE-2020-36216: Data race in eventio

> A data race in the eventio crate allows memory corruption, potentially leading to code execution or denial of service.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jan 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-69vj-xx27-g45w, RUSTSEC-2020-0108

## What is CVE-2020-36216?

CVE-2020-36216 is a medium-severity vulnerability in n/a, published on 22 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in Input<R> in the eventio crate before 0.5.1 for Rust. Because a non-Send type can be sent to a different thread, a data race and memory corruption can occur.

Weakness: CWE-787 (Out-of-bounds Write), CWE-662 (Improper Synchronization)

## Which versions are affected by CVE-2020-36216?

3 open source packages ship an affected version, including eventio. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `eventio` | crates.io | All versions | 0.5.1 |
| `eventio` | crates.io | All versions | 0.5.1 |
| `eventio` | crates.io | From 0.0.0-0 | 0.5.1 |

Products: Petabi Eventio.

## How do I fix CVE-2020-36216?

Upgrade eventio to 0.5.1 or later.

## Is CVE-2020-36216 being exploited?

There is no known exploitation of CVE-2020-36216 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-36216 and fix it if it is affected.

What it is: CVE-2020-36216 is a medium-severity vulnerability in n/a, published on 22 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-36216 in the wild and no public exploit code.

Affected packages and fixed versions:
- eventio (crates.io): affected all versions; fixed in 0.5.1
- eventio (crates.io): affected all versions; fixed in 0.5.1
- eventio (crates.io): affected from 0.0.0-0; fixed in 0.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-36216/ (Markdown: https://insights.sbomify.com/CVE-2020-36216/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-36216
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-36216
- OSV: https://osv.dev/vulnerability/CVE-2020-36216

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-36216/
Summaries are generated and may contain mistakes; the official description above is the record.
