# CVE-2020-36217: Data race in may_queue

> A memory corruption vulnerability in the Rust may_queue crate allows attackers to potentially execute arbitrary code or cause denial of service due to missing thread-safety bounds.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jan 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-pphf-f93w-gc84, RUSTSEC-2020-0111

## What is CVE-2020-36217?

CVE-2020-36217 is a medium-severity memory corruption vulnerability in n/a, published on 22 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the may_queue crate through 2020-11-10 for Rust. Because Queue does not have bounds on its Send trait or Sync trait, memory corruption can occur.

Weakness: CWE-787 (Out-of-bounds Write), CWE-662 (Improper Synchronization)

## Which versions are affected by CVE-2020-36217?

3 open source packages ship an affected version, including may_queue. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `may_queue` | crates.io | All versions to 0.1.8 | None |
| `may_queue` | crates.io | All versions to 0.1.8 | None |
| `may_queue` | crates.io | From 0.0.0-0 | 0.1.8 |

Products: May Queue Project May Queue.

## How do I fix CVE-2020-36217?

Upgrade may_queue to 0.1.8 or later.

## Is CVE-2020-36217 being exploited?

There is no known exploitation of CVE-2020-36217 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-36217 and fix it if it is affected.

What it is: CVE-2020-36217 is a medium-severity memory corruption vulnerability in n/a, published on 22 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-36217 in the wild and no public exploit code.

Affected packages and fixed versions:
- may_queue (crates.io): affected all versions up to 0.1.8; no fix listed
- may_queue (crates.io): affected all versions up to 0.1.8; no fix listed
- may_queue (crates.io): affected from 0.0.0-0; fixed in 0.1.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-36217/ (Markdown: https://insights.sbomify.com/CVE-2020-36217/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-36217
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-36217
- OSV: https://osv.dev/vulnerability/CVE-2020-36217

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-36217/
Summaries are generated and may contain mistakes; the official description above is the record.
