# CVE-2020-36225: Use after free in n/a

> A double free vulnerability in OpenLDAP's saslAuthzTo processing allows attackers to crash the slapd service, causing denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Jan 2021
- **Updated:** 14 Oct 2026
- **Also known as:** ALPINE-CVE-2020-36225, BIT-openldap-2020-36225, CLEANSTART-2026-LF09803, DEBIAN-CVE-2020-36225, GHSA-whx8-g4mc-7mcq, JLSEC-2026-167, UBUNTU-CVE-2020-36225

## What is CVE-2020-36225?

CVE-2020-36225 is a high-severity use after free vulnerability in Apple Macos, published on 25 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A flaw was discovered in OpenLDAP before 2.4.57 leading to a double free and slapd crash in the saslAuthzTo processing, resulting in denial of service.

Weakness: CWE-415 (Double Free)

## Which versions are affected by CVE-2020-36225?

1 open source package ship an affected version, including openldap. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openldap` | Bitnami | All versions | 2.4.57 |

Products: Apple Macos, Debian Debian Linux, Openldap Openldap.

## How do I fix CVE-2020-36225?

Upgrade openldap to 2.4.57 or later.

## Is CVE-2020-36225 being exploited?

There is no known exploitation of CVE-2020-36225 in the wild and no public exploit code.

## Other vulnerabilities in Apple Macos

- [CVE-2026-65400](https://insights.sbomify.com/CVE-2026-65400/): Apple macOS Improper Authentication (critical 9.8, exploited in the wild)
- [CVE-2024-44146](https://insights.sbomify.com/CVE-2024-44146/): Security feature bypass in macOS (critical 10.0)
- [CVE-2024-44148](https://insights.sbomify.com/CVE-2024-44148/): Security feature bypass in macOS (critical 10.0)
- [CVE-2023-38586](https://insights.sbomify.com/CVE-2023-38586/): Security feature bypass in macOS (critical 10.0)
- [CVE-2023-40455](https://insights.sbomify.com/CVE-2023-40455/): Security feature bypass in macOS (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-36225 and fix it if it is affected.

What it is: CVE-2020-36225 is a high-severity use after free vulnerability in Apple Macos, published on 25 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-36225 in the wild and no public exploit code.

Affected packages and fixed versions:
- openldap (Bitnami): affected all versions; fixed in 2.4.57

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-36225/ (Markdown: https://insights.sbomify.com/CVE-2020-36225/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-36225
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-36225
- OSV: https://osv.dev/vulnerability/CVE-2020-36225

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-36225/
Summaries are generated and may contain mistakes; the official description above is the record.
