# CVE-2020-36230: A flaw was discovered in OpenLDAP before 2.4.57 leading in an assertion failure in slapd in the X.509 DN parsing in decode.c ber_next_elemen


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 25 Jan 2021
- **Updated:** 14 Oct 2026
- **Also known as:** ALPINE-CVE-2020-36230, BIT-openldap-2020-36230, CLEANSTART-2026-LQ91791, DEBIAN-CVE-2020-36230, GHSA-5g5w-44wh-969g, JLSEC-2026-172, UBUNTU-CVE-2020-36230

## What is CVE-2020-36230?

CVE-2020-36230 is a high-severity vulnerability in Apple Mac Os X, published on 25 Jan 2021. 

### Official description

A flaw was discovered in OpenLDAP before 2.4.57 leading in an assertion failure in slapd in the X.509 DN parsing in decode.c ber_next_element, resulting in denial of service.

Weakness: CWE-617 (Reachable Assertion)

## Which versions are affected by CVE-2020-36230?

1 open source package ship an affected version, including openldap. It affects 5 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openldap` | Bitnami | All versions | 2.4.57 |

Products: Apache Bookkeeper, Apple Mac Os X, Apple Macos, Debian Debian Linux, Openldap Openldap.

## How do I fix CVE-2020-36230?

Upgrade openldap to 2.4.57 or later.

## Is CVE-2020-36230 being exploited?

There is no known exploitation of CVE-2020-36230 in the wild and no public exploit code.

## Other vulnerabilities in Apple Mac Os X

- [CVE-2019-17571](https://insights.sbomify.com/CVE-2019-17571/): Deserialization of Untrusted Data in Log4j (critical 9.8)
- [CVE-2017-6891](https://insights.sbomify.com/CVE-2017-6891/): Memory corruption in GnuTLS libtasn1 (high 8.8)
- [CVE-2019-19906](https://insights.sbomify.com/CVE-2019-19906/): Memory corruption in n/a (high 7.5)
- [CVE-2020-23922](https://insights.sbomify.com/CVE-2020-23922/): Memory corruption in n/a (high 7.1)
- [CVE-2022-32531](https://insights.sbomify.com/CVE-2022-32531/): Apache BookKeeper: Java Client Uses Connection to Host that Failed Hostname Verification (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-36230 and fix it if it is affected.

What it is: CVE-2020-36230 is a high-severity vulnerability in Apple Mac Os X, published on 25 Jan 2021. 
Exploitation: There is no known exploitation of CVE-2020-36230 in the wild and no public exploit code.

Affected packages and fixed versions:
- openldap (Bitnami): affected all versions; fixed in 2.4.57

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-36230/ (Markdown: https://insights.sbomify.com/CVE-2020-36230/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-36230
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-36230
- OSV: https://osv.dev/vulnerability/CVE-2020-36230

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-36230/
Summaries are generated and may contain mistakes; the official description above is the record.
