# CVE-2020-36245: GramAddict bot uses dependency with reverse tcp backdoor

> Remote attackers on the same network can execute arbitrary code via the exposed UIAutomator2 service due to missing authentication.

- **Severity:** High 8.8 (`CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Feb 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-q5h6-49gg-2wfg, PYSEC-2021-65

## What is CVE-2020-36245?

CVE-2020-36245 is a high-severity missing authorization vulnerability in n/a, published on 17 Feb 2021. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

GramAddict through 1.2.3 allows remote attackers to execute arbitrary code because of use of UIAutomator2 and ATX-Agent. The attacker must be able to reach TCP port 7912, e.g., by being on the same Wi-Fi network.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2020-36245?

3 open source packages ship an affected version, including gramaddict and GramAddict. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gramaddict` | PyPI | All versions | 1.2.4 |
| `gramaddict` | PyPI | All versions | 1.2.5 |
| `GramAddict` | PyPI | All versions | 1.2.5 |

Products: Gramaddict Gramaddict.

## How do I fix CVE-2020-36245?

Upgrade gramaddict to a fixed version for your release line: 1.2.4 or 1.2.5.

## Is CVE-2020-36245 being exploited?

There is no known exploitation of CVE-2020-36245 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-36245 and fix it if it is affected.

What it is: CVE-2020-36245 is a high-severity missing authorization vulnerability in n/a, published on 17 Feb 2021. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-36245 in the wild and no public exploit code.

Affected packages and fixed versions:
- gramaddict (PyPI): affected all versions; fixed in 1.2.4
- gramaddict (PyPI): affected all versions; fixed in 1.2.5
- GramAddict (PyPI): affected all versions; fixed in 1.2.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-36245/ (Markdown: https://insights.sbomify.com/CVE-2020-36245/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-36245
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-36245
- OSV: https://osv.dev/vulnerability/CVE-2020-36245

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-36245/
Summaries are generated and may contain mistakes; the official description above is the record.
