CVE-2020-36282 Unsafe Deserialization that can Result in Code Execution
An attacker can execute arbitrary code by sending crafted StreamMessage data to the JMS Client for RabbitMQ.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-36282?
CVE-2020-36282 is a critical unsafe deserialization vulnerability in n/a, published on 12 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
JMS Client for RabbitMQ 1.x before 1.15.2 and 2.x before 2.2.0 is vulnerable to unsafe deserialization that can result in code execution via crafted StreamMessage data.
Weakness: CWE-502
Which versions are affected by CVE-2020-36282?
4 open source packages ship an affected version, including com.rabbitmq.jms:rabbitmq-jms. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
com.rabbitmq.jms:rabbitmq-jms Maven | From 1.0 | 1.15.2 |
com.rabbitmq.jms:rabbitmq-jms Maven | From 1.0 | 1.15.2 |
com.rabbitmq.jms:rabbitmq-jms Maven | From 2.0 | 2.2.0 |
com.rabbitmq.jms:rabbitmq-jms Maven | From 2.0 | 2.2.0 |
Products include Rabbitmq Jms Client.
How do I fix CVE-2020-36282?
Upgrade com.rabbitmq.jms:rabbitmq-jms to a fixed version for your release line: 1.15.2 or 2.2.0.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2020-36282 being exploited?
There is no known exploitation of CVE-2020-36282 in the wild and no public exploit code.
Sources
Also known as GHSA-v525-c3g5-cg9p.