# CVE-2020-36282: Unsafe Deserialization that can Result in Code Execution

> An attacker can execute arbitrary code by sending crafted StreamMessage data to the JMS Client for RabbitMQ.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Mar 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-v525-c3g5-cg9p

## What is CVE-2020-36282?

CVE-2020-36282 is a critical unsafe deserialization vulnerability in n/a, published on 12 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

JMS Client for RabbitMQ 1.x before 1.15.2 and 2.x before 2.2.0 is vulnerable to unsafe deserialization that can result in code execution via crafted StreamMessage data.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2020-36282?

4 open source packages ship an affected version, including com.rabbitmq.jms:rabbitmq-jms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.rabbitmq.jms:rabbitmq-jms` | Maven | From 1.0 | 1.15.2 |
| `com.rabbitmq.jms:rabbitmq-jms` | Maven | From 1.0 | 1.15.2 |
| `com.rabbitmq.jms:rabbitmq-jms` | Maven | From 2.0 | 2.2.0 |
| `com.rabbitmq.jms:rabbitmq-jms` | Maven | From 2.0 | 2.2.0 |

Products: Rabbitmq Jms Client.

## How do I fix CVE-2020-36282?

Upgrade com.rabbitmq.jms:rabbitmq-jms to a fixed version for your release line: 1.15.2 or 2.2.0.

## Is CVE-2020-36282 being exploited?

There is no known exploitation of CVE-2020-36282 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-36282 and fix it if it is affected.

What it is: CVE-2020-36282 is a critical unsafe deserialization vulnerability in n/a, published on 12 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-36282 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.rabbitmq.jms:rabbitmq-jms (Maven): affected from 1.0; fixed in 1.15.2
- com.rabbitmq.jms:rabbitmq-jms (Maven): affected from 1.0; fixed in 1.15.2
- com.rabbitmq.jms:rabbitmq-jms (Maven): affected from 2.0; fixed in 2.2.0
- com.rabbitmq.jms:rabbitmq-jms (Maven): affected from 2.0; fixed in 2.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-36282/ (Markdown: https://insights.sbomify.com/CVE-2020-36282/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-36282
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-36282
- OSV: https://osv.dev/vulnerability/CVE-2020-36282

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-36282/
Summaries are generated and may contain mistakes; the official description above is the record.
