CVE-2020-36307 Cross-site scripting in n/a
Attackers can inject malicious scripts via textile inline links in Redmine, potentially leading to session hijacking or code execution.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2020-36307?
CVE-2020-36307 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 6 Apr 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Redmine before 4.0.7 and 4.1.x before 4.1.1 has stored XSS via textile inline links.
Weakness: CWE-79
Which versions are affected by CVE-2020-36307?
1 open source package ship an affected version, including redmine. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
redmine Bitnami | All versions | 4.0.7, 4.1.1 |
Products include Debian Debian Linux, Redmine Redmine.
How do I fix CVE-2020-36307?
Upgrade redmine to a fixed version for your release line: 4.0.7 or 4.1.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2020-36307 being exploited?
There is no known exploitation of CVE-2020-36307 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as BIT-redmine-2020-36307, DEBIAN-CVE-2020-36307, GHSA-6q3j-grpp-68qp, UBUNTU-CVE-2020-36307.