{"answers":{"affected":"1 open source package ship an affected version, including openresty. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-36309 in the wild and no public exploit code.","fix":"Upgrade openresty to 0.10.16 or later.","what":"CVE-2020-36309 is a medium-severity vulnerability in n/a, published on 6 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-36309 and fix it if it is affected.\n\nWhat it is: CVE-2020-36309 is a medium-severity vulnerability in n/a, published on 6 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-36309 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- openresty (Bitnami): affected all versions; fixed in 0.10.16\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-36309/ (Markdown: https://insights.sbomify.com/CVE-2020-36309/index.md)","id":"CVE-2020-36309","markdown":"https://insights.sbomify.com/CVE-2020-36309/index.md","name":"CVE-2020-36309","record":{"aliases":["BIT-openresty-2020-36309","DEBIAN-CVE-2020-36309","GHSA-j8m6-95xp-pmp6","UBUNTU-CVE-2020-36309"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["other"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenResty Lua module","requires_auth":"none","summary":"The OpenResty Lua module allows unsafe characters in URI or header mutations, potentially leading to request smuggling or header injection issues.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"lua-nginx-module","vendor":"openresty"}],"cvss":{"score":5.3,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[],"description":"ngx_http_lua_module (aka lua-nginx-module) before 0.10.16 in OpenResty allows unsafe characters in an argument when using the API to mutate a URI, or a request or response header.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Other in n/a","id":"CVE-2020-36309","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"other","year":"2020"},"n_packages":1,"n_references":4,"next":{"headline":"Denial of service in n/a","id":"CVE-2020-36310"},"packages":[{"ecosystem":"Bitnami","fixed":["0.10.16"],"introduced":["0"],"last_affected":[],"package":"openresty","purl":"pkg:bitnami/openresty","source":"BIT-openresty-2020-36309"}],"prev":{"headline":"Information disclosure in n/a","id":"CVE-2020-36308"},"products":["n/a"],"published":"2021-04-06","related":[{"cvss_score":7.7,"headline":"Other in n/a","id":"CVE-2024-33452","kev_date_added":null,"published":"2025-04-22"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2025-11-03","vendors":["n/a"]},"summary":"The OpenResty Lua module allows unsafe characters in URI or header mutations, potentially leading to request smuggling or header injection issues.","url":"https://insights.sbomify.com/CVE-2020-36309/"}