{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2020-36314 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"CVE-2020-36314 is a low-severity path traversal vulnerability in Fedoraproject Fedora, published on 7 Apr 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-36314 and fix it if it is affected.\n\nWhat it is: CVE-2020-36314 is a low-severity path traversal vulnerability in Fedoraproject Fedora, published on 7 Apr 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-36314 in the wild and no public exploit code.\n\nAffected product: Fedoraproject Fedora. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-36314/ (Markdown: https://insights.sbomify.com/CVE-2020-36314/index.md)","id":"CVE-2020-36314","markdown":"https://insights.sbomify.com/CVE-2020-36314/index.md","name":"CVE-2020-36314","record":{"aliases":["CLSA-2022-1643124469","DEBIAN-CVE-2020-36314","GHSA-xf7f-5p7r-xc3c","MGASA-2021-0311","RHSA-2021:4179","RLSA-2021:4179","SUSE-SU-2025:0032-1","UBUNTU-CVE-2020-36314","USN-4927-1"],"analysis":{"component_type":"desktop_application","fix_type":"patch","impacts":["data_modify","code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"GNOME file-roller","requires_auth":"low_privilege","summary":"An attacker can exploit a directory traversal vulnerability in GNOME file-roller to write files outside the intended extraction directory, potentially leading to code execution.","user_interaction":"required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"file-roller","vendor":"gnome"}],"cvss":{"score":3.9,"severity":"low","source":"nvd","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-59","name":"Improper Link Resolution Before File Access"}],"description":"fr-archive-libarchive.c in GNOME file-roller through 3.38.0, as used by GNOME Shell and other software, allows Directory Traversal during extraction because it lacks a check of whether a file's parent is a symlink in certain complex situations. NOTE: this issue exists because of an incomplete fix for CVE-2020-11736.","ecosystems":["Red Hat:enterprise_linux:8::appstream","Rocky Linux:8","SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Path traversal in n/a","id":"CVE-2020-36314","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"fedoraproject:fedora","products":["fedoraproject:fedora"],"type":"path_traversal","year":"2020"},"n_packages":5,"n_references":3,"next":{"headline":"Weak cryptography in n/a","id":"CVE-2020-36315"},"packages":[{"ecosystem":"Red Hat:enterprise_linux:8::appstream","fixed":["0:3.28.1-4.el8"],"introduced":["0"],"last_affected":[],"package":"file-roller","purl":"pkg:rpm/redhat/file-roller","source":"RHSA-2021:4179"},{"ecosystem":"Red Hat:enterprise_linux:8::appstream","fixed":["0:3.28.1-4.el8"],"introduced":["0"],"last_affected":[],"package":"file-roller-debuginfo","purl":"pkg:rpm/redhat/file-roller-debuginfo","source":"RHSA-2021:4179"},{"ecosystem":"Red Hat:enterprise_linux:8::appstream","fixed":["0:3.28.1-4.el8"],"introduced":["0"],"last_affected":[],"package":"file-roller-debugsource","purl":"pkg:rpm/redhat/file-roller-debugsource","source":"RHSA-2021:4179"},{"ecosystem":"Rocky Linux:8","fixed":["0:3.28.1-4.el8"],"introduced":["0"],"last_affected":[],"package":"file-roller","purl":"pkg:rpm/rocky-linux/file-roller?distro=rocky-linux-8\u0026epoch=0","source":"RLSA-2021:4179"},{"ecosystem":"SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5","fixed":["3.20.3-15.9.1"],"introduced":["0"],"last_affected":[],"package":"file-roller","purl":"pkg:rpm/suse/file-roller\u0026distro=SUSE%20Linux%20Enterprise%20Server%20LTSS%20Extended%20Security%2012%20SP5","source":"SUSE-SU-2025:0032-1"}],"prev":{"headline":"Use after free in n/a","id":"CVE-2020-36313"},"products":["n/a"],"published":"2021-04-07","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"BSD","name":"Rocky Linux","prefix":"RLSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"An attacker can exploit a directory traversal vulnerability in GNOME file-roller to write files outside the intended extraction directory, potentially leading to code execution.","url":"https://insights.sbomify.com/CVE-2020-36314/"}