# CVE-2020-36319: Potential sensitive data exposure in applications using Vaadin 15

> Insecure default ObjectMapper configuration in Vaadin flow-server may expose sensitive data in applications using RestControllers.

- **Severity:** Low 3.1 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Apr 2021
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-rjww-2x8v-m9v9

## What is CVE-2020-36319?

CVE-2020-36319 is a low-severity vulnerability in Vaadin, published on 23 Apr 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Insecure configuration of default ObjectMapper in com.vaadin:flow-server versions 3.0.0 through 3.0.5 (Vaadin 15.0.0 through 15.0.4) may expose sensitive data if the application also uses e.g. @RestController

Weakness: CWE-668 (Exposure of Resource to Wrong Sphere), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2020-36319?

2 open source packages ship an affected version, including com.vaadin:flow-server. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.vaadin:flow-server` | Maven | From 3.0.0 | 3.0.6 |
| `com.vaadin:flow-server` | Maven | From 3.0.0 | 3.0.6 |

Products: Vaadin Flow, Vaadin Vaadin.

## How do I fix CVE-2020-36319?

Upgrade com.vaadin:flow-server to 3.0.6 or later.

## Is CVE-2020-36319 being exploited?

There is no known exploitation of CVE-2020-36319 in the wild and no public exploit code.

## Other vulnerabilities in Vaadin

- [CVE-2021-31407](https://insights.sbomify.com/CVE-2021-31407/): Server classes and resources exposure in OSGi applications using Vaadin 12-14 and 19 (high 8.6)
- [CVE-2021-31405](https://insights.sbomify.com/CVE-2021-31405/): Regular expression denial of service (ReDoS) in EmailField component in Vaadin 14 and 15-17 (high 7.5)
- [CVE-2021-31411](https://insights.sbomify.com/CVE-2021-31411/): Insecure temporary directory usage in frontend build functionality of Vaadin 14 and 15-19 (medium 6.3)
- [CVE-2021-31408](https://insights.sbomify.com/CVE-2021-31408/): Server session is not invalidated when logout() helper method of Authentication module is used in Vaadin 18-19 (medium 6.3)
- [CVE-2019-25027](https://insights.sbomify.com/CVE-2019-25027/): Reflected cross-site scripting in default RouteNotFoundError view in Vaadin 10 and 11-13 (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-36319 and fix it if it is affected.

What it is: CVE-2020-36319 is a low-severity vulnerability in Vaadin, published on 23 Apr 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-36319 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.vaadin:flow-server (Maven): affected from 3.0.0; fixed in 3.0.6
- com.vaadin:flow-server (Maven): affected from 3.0.0; fixed in 3.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-36319/ (Markdown: https://insights.sbomify.com/CVE-2020-36319/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-36319
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-36319
- OSV: https://osv.dev/vulnerability/CVE-2020-36319

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-36319/
Summaries are generated and may contain mistakes; the official description above is the record.
