# CVE-2020-36388: File upload in n/a

> Attackers can upload and execute malicious PHAR archives in CiviCRM, leading to remote code execution.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jun 2021
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-civicrm-2020-36388, DEBIAN-CVE-2020-36388, GHSA-rqh9-9xqh-854h, UBUNTU-CVE-2020-36388

## What is CVE-2020-36388?

CVE-2020-36388 is a high-severity vulnerability in n/a, published on 17 Jun 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In CiviCRM before 5.21.3 and 5.22.x through 5.24.x before 5.24.3, users may be able to upload and execute a crafted PHAR archive.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2020-36388?

1 open source package ship an affected version, including civicrm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `civicrm` | Bitnami | All versions | 5.21.3, 5.24.3 |

Products: Civicrm Civicrm.

## How do I fix CVE-2020-36388?

Upgrade civicrm to a fixed version for your release line: 5.21.3 or 5.24.3.

## Is CVE-2020-36388 being exploited?

There is no known exploitation of CVE-2020-36388 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2018-1999022](https://insights.sbomify.com/CVE-2018-1999022/): Code injection in n/a (critical 9.8)
- [CVE-2013-5957](https://insights.sbomify.com/CVE-2013-5957/): SQL injection in n/a (high 7.5)
- [CVE-2013-4662](https://insights.sbomify.com/CVE-2013-4662/): CiviCRM SQL injection vulnerability via Quick Search API (medium 6.5)
- [CVE-2025-65187](https://insights.sbomify.com/CVE-2025-65187/): Cross-site scripting in n/a (medium 6.1)
- [CVE-2011-5239](https://insights.sbomify.com/CVE-2011-5239/): Weak cryptography in n/a (medium 5.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-36388 and fix it if it is affected.

What it is: CVE-2020-36388 is a high-severity vulnerability in n/a, published on 17 Jun 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-36388 in the wild and no public exploit code.

Affected packages and fixed versions:
- civicrm (Bitnami): affected all versions; fixed in 5.21.3, 5.24.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-36388/ (Markdown: https://insights.sbomify.com/CVE-2020-36388/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-36388
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-36388
- OSV: https://osv.dev/vulnerability/CVE-2020-36388

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-36388/
Summaries are generated and may contain mistakes; the official description above is the record.
