CVE-2020-36389 Cross-site request forgery in n/a

Medium 4.3 Published Updated

An attacker can trick authenticated users into performing unwanted actions in CiviCRM via a CSRF vulnerability in the CKEditor configuration form.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2020-36389?

CVE-2020-36389 is a medium-severity vulnerability in n/a, published on 17 Jun 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

In CiviCRM before 5.28.1 and CiviCRM ESR before 5.27.5 ESR, the CKEditor configuration form allows CSRF.

Weakness: CWE-352

Which versions are affected by CVE-2020-36389?

1 open source package ship an affected version, including civicrm. It affects 1 product.

PackageAffectedFixed in
civicrm BitnamiAll versions5.27.5, 5.28.1

Products include Civicrm Civicrm.

How do I fix CVE-2020-36389?

Upgrade civicrm to a fixed version for your release line: 5.27.5 or 5.28.1.

Is CVE-2020-36389 being exploited?

There is no known exploitation of CVE-2020-36389 in the wild and no public exploit code.

Sources

Also known as BIT-civicrm-2020-36389, DEBIAN-CVE-2020-36389, GHSA-pxgv-6gmm-ggxw, UBUNTU-CVE-2020-36389.

Is CVE-2020-36389 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free