# CVE-2020-36437: Data race in conqueue

> Unconditional Send and Sync implementations in the conqueue crate allow data races, potentially leading to memory corruption or crashes in Rust applications.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Aug 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-368f-29c3-4f2r, RUSTSEC-2020-0117

## What is CVE-2020-36437?

CVE-2020-36437 is a high-severity vulnerability in n/a, published on 8 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the conqueue crate before 0.4.0 for Rust. There are unconditional implementations of Send and Sync for QueueSender<T>.

Weakness: CWE-362 (Concurrent Execution using Shared Resource with Improper Synchronization)

## Which versions are affected by CVE-2020-36437?

3 open source packages ship an affected version, including conqueue. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `conqueue` | crates.io | All versions | 0.4.0 |
| `conqueue` | crates.io | All versions | 0.4.0 |
| `conqueue` | crates.io | From 0.0.0-0 | 0.4.0 |

Products: Conqueue Project Conqueue.

## How do I fix CVE-2020-36437?

Upgrade conqueue to 0.4.0 or later.

## Is CVE-2020-36437 being exploited?

There is no known exploitation of CVE-2020-36437 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-36437 and fix it if it is affected.

What it is: CVE-2020-36437 is a high-severity vulnerability in n/a, published on 8 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-36437 in the wild and no public exploit code.

Affected packages and fixed versions:
- conqueue (crates.io): affected all versions; fixed in 0.4.0
- conqueue (crates.io): affected all versions; fixed in 0.4.0
- conqueue (crates.io): affected from 0.0.0-0; fixed in 0.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-36437/ (Markdown: https://insights.sbomify.com/CVE-2020-36437/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-36437
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-36437
- OSV: https://osv.dev/vulnerability/CVE-2020-36437

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-36437/
Summaries are generated and may contain mistakes; the official description above is the record.
