# CVE-2020-36443: Use of Uninitialized Resource in libp2p-deflate

> An uninitialized buffer passed to a user-provided trait function in the libp2p-deflate crate can lead to memory corruption and potential code execution.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Aug 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-gvcp-948f-8f2p, RUSTSEC-2020-0123

## What is CVE-2020-36443?

CVE-2020-36443 is a critical memory corruption vulnerability in n/a, published on 8 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the libp2p-deflate crate before 0.27.1 for Rust. An uninitialized buffer is passed to AsyncRead::poll_read(), which is a user-provided trait function.

Weakness: CWE-908 (Use of Uninitialized Resource)

## Which versions are affected by CVE-2020-36443?

3 open source packages ship an affected version, including libp2p-deflate. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libp2p-deflate` | crates.io | All versions | 0.27.1 |
| `libp2p-deflate` | crates.io | All versions | 0.27.1 |
| `libp2p-deflate` | crates.io | From 0.0.0-0 | 0.27.1 |

Products: Libp2p Libp2p-Deflate.

## How do I fix CVE-2020-36443?

Upgrade libp2p-deflate to 0.27.1 or later.

## Is CVE-2020-36443 being exploited?

There is no known exploitation of CVE-2020-36443 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-36443 and fix it if it is affected.

What it is: CVE-2020-36443 is a critical memory corruption vulnerability in n/a, published on 8 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-36443 in the wild and no public exploit code.

Affected packages and fixed versions:
- libp2p-deflate (crates.io): affected all versions; fixed in 0.27.1
- libp2p-deflate (crates.io): affected all versions; fixed in 0.27.1
- libp2p-deflate (crates.io): affected from 0.0.0-0; fixed in 0.27.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-36443/ (Markdown: https://insights.sbomify.com/CVE-2020-36443/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-36443
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-36443
- OSV: https://osv.dev/vulnerability/CVE-2020-36443

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-36443/
Summaries are generated and may contain mistakes; the official description above is the record.
