{"answers":{"affected":"4 open source packages ship an affected version, including omniauth. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-36599 in the wild and no public exploit code.","fix":"Upgrade omniauth to a fixed version for your release line: 1.9.2 or 2.0.0.","what":"CVE-2020-36599 is a critical cross-site scripting vulnerability in n/a, published on 18 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-36599 and fix it if it is affected.\n\nWhat it is: CVE-2020-36599 is a critical cross-site scripting vulnerability in n/a, published on 18 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-36599 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- omniauth (RubyGems): affected all versions; fixed in 1.9.2\n- omniauth (RubyGems): affected all versions; fixed in 1.9.2\n- omniauth (RubyGems): affected from 2.0.0.pre.rc1; fixed in 2.0.0\n- omniauth (RubyGems): affected from 2.0.0.pre.rc1; fixed in 2.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-36599/ (Markdown: https://insights.sbomify.com/CVE-2020-36599/index.md)","id":"CVE-2020-36599","markdown":"https://insights.sbomify.com/CVE-2020-36599/index.md","name":"CVE-2020-36599","record":{"aliases":["DEBIAN-CVE-2020-36599","GHSA-pm55-qfxr-h247","UBUNTU-CVE-2020-36599"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby authentication library","requires_auth":"none","summary":"Attackers can inject malicious scripts via unescaped message keys in OmniAuth failure endpoints, potentially leading to code execution.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"omniauth","vendor":"omniauth"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-116","name":"Improper Encoding or Escaping of Output"}],"description":"lib/omniauth/failure_endpoint.rb in OmniAuth before 1.9.2 (and before 2.0) does not escape the message_key value.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OmniAuth's `lib/omniauth/failure_endpoint.rb` does not escape `message_key` value","id":"CVE-2020-36599","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"xss","year":"2020"},"n_packages":4,"n_references":2,"next":{"headline":"Memory corruption in EMUI","id":"CVE-2020-36600"},"packages":[{"ecosystem":"RubyGems","fixed":["1.9.2"],"introduced":["0"],"last_affected":[],"package":"omniauth","purl":null,"source":"GHSA-pm55-qfxr-h247"},{"ecosystem":"RubyGems","fixed":["1.9.2"],"introduced":["0"],"last_affected":[],"package":"omniauth","purl":"pkg:gem/omniauth","source":"GHSA-pm55-qfxr-h247"},{"ecosystem":"RubyGems","fixed":["2.0.0"],"introduced":["2.0.0.pre.rc1"],"last_affected":[],"package":"omniauth","purl":null,"source":"GHSA-pm55-qfxr-h247"},{"ecosystem":"RubyGems","fixed":["2.0.0"],"introduced":["2.0.0.pre.rc1"],"last_affected":[],"package":"omniauth","purl":"pkg:gem/omniauth","source":"GHSA-pm55-qfxr-h247"}],"prev":{"headline":"Authentication bypass in github.com/nanobox-io/golang-nanoauth","id":"CVE-2020-36569"},"products":["n/a"],"published":"2022-08-18","related":[{"cvss_score":8.8,"headline":"OmniAuth Ruby gem Cross-site Request Forgery in request phase","id":"CVE-2015-9284","kev_date_added":null,"published":"2019-04-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Attackers can inject malicious scripts via unescaped message keys in OmniAuth failure endpoints, potentially leading to code execution.","url":"https://insights.sbomify.com/CVE-2020-36599/"}