# CVE-2020-36608: Tribal Systems Zenario CMS Error Log Module admin_organizer.js cross site scripting

> Remote attackers can execute arbitrary scripts in the Zenario CMS Error Log Module via cross-site scripting, potentially compromising user sessions.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Nov 2022
- **Updated:** 15 Apr 2025
- **Also known as:** GHSA-f92p-f8r2-c87q

## What is CVE-2020-36608?

CVE-2020-36608 is a low-severity cross-site scripting vulnerability in Tribal Systems Zenario CMS, published on 2 Nov 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A vulnerability, which was classified as problematic, has been found in Tribal Systems Zenario CMS. Affected by this issue is some unknown functionality of the file admin_organizer.js of the component Error Log Module. The manipulation leads to cross site scripting. The attack may be launched remotely. The name of the patch is dfd0afacb26c3682a847bea7b49ea440b63f3baa. It is recommended to apply a patch to fix this issue. The identifier of this vulnerability is VDB-212816.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-707 (Improper Neutralization)

## Which versions are affected by CVE-2020-36608?

2 open source packages ship an affected version, including tribalsystems/zenario. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tribalsystems/zenario` | Packagist | All versions | 8.5.51340 |
| `tribalsystems/zenario` | Packagist | All versions | 8.5.51340 |

Products: Tribalsystems Zenario.

## How do I fix CVE-2020-36608?

Upgrade tribalsystems/zenario to 8.5.51340 or later.

## Is CVE-2020-36608 being exploited?

There is no known exploitation of CVE-2020-36608 in the wild and no public exploit code.

## Other vulnerabilities in Tribal Systems Zenario CMS

- [CVE-2022-44136](https://insights.sbomify.com/CVE-2022-44136/): Zenario CMS is vulnerable to Remote Code Execution (RCE). (critical 9.8)
- [CVE-2021-26830](https://insights.sbomify.com/CVE-2021-26830/): SQL Injection in tribalsystems/zenario (critical 9.1)
- [CVE-2018-18420](https://insights.sbomify.com/CVE-2018-18420/): Zenario CMS vulnerable to CSRF (high 8.8)
- [CVE-2018-5960](https://insights.sbomify.com/CVE-2018-5960/): SQL Injection in Zenario 7.1-7.6 (high 8.8)
- [CVE-2021-42171](https://insights.sbomify.com/CVE-2021-42171/): Unrestricted Upload of File with Dangerous Type in Zenario CMS (high 7.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-36608 and fix it if it is affected.

What it is: CVE-2020-36608 is a low-severity cross-site scripting vulnerability in Tribal Systems Zenario CMS, published on 2 Nov 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-36608 in the wild and no public exploit code.

Affected packages and fixed versions:
- tribalsystems/zenario (Packagist): affected all versions; fixed in 8.5.51340
- tribalsystems/zenario (Packagist): affected all versions; fixed in 8.5.51340

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-36608/ (Markdown: https://insights.sbomify.com/CVE-2020-36608/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-36608
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-36608
- OSV: https://osv.dev/vulnerability/CVE-2020-36608

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-36608/
Summaries are generated and may contain mistakes; the official description above is the record.
