# CVE-2020-36620: Brondahl EnumStringValues EnumExtensions.cs GetStringValuesWithPreferences_Uncache resource consumption

> Attackers can cause resource consumption via the GetStringValuesWithPreferences_Uncache function in the Brondahl EnumStringValues library.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Dec 2022
- **Updated:** 15 Apr 2025
- **Also known as:** GHSA-vq23-hwg7-hxrh

## What is CVE-2020-36620?

CVE-2020-36620 is a low-severity denial of service vulnerability in Brondahl EnumStringValues, published on 21 Dec 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability was found in Brondahl EnumStringValues up to 4.0.0. It has been declared as problematic. This vulnerability affects the function GetStringValuesWithPreferences_Uncache of the file EnumStringValues/EnumExtensions.cs. The manipulation leads to resource consumption. Upgrading to version 4.0.1 is able to address this issue. The name of the patch is c0fc7806beb24883cc2f9543ebc50c0820297307. It is recommended to upgrade the affected component. VDB-216466 is the identifier assigned to this vulnerability.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2020-36620?

2 open source packages ship an affected version, including EnumStringValues. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `EnumStringValues` | NuGet | All versions | 4.0.2 |
| `EnumStringValues` | NuGet | All versions | 4.0.2 |

Products: Enumstringvalues Project Enumstringvalues.

## How do I fix CVE-2020-36620?

Upgrade EnumStringValues to 4.0.2 or later.

## Is CVE-2020-36620 being exploited?

There is no known exploitation of CVE-2020-36620 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-36620 and fix it if it is affected.

What it is: CVE-2020-36620 is a low-severity denial of service vulnerability in Brondahl EnumStringValues, published on 21 Dec 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-36620 in the wild and no public exploit code.

Affected packages and fixed versions:
- EnumStringValues (NuGet): affected all versions; fixed in 4.0.2
- EnumStringValues (NuGet): affected all versions; fixed in 4.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-36620/ (Markdown: https://insights.sbomify.com/CVE-2020-36620/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-36620
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-36620
- OSV: https://osv.dev/vulnerability/CVE-2020-36620

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-36620/
Summaries are generated and may contain mistakes; the official description above is the record.
