{"answers":{"affected":"2 open source packages ship an affected version, including text_helpers. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-36624 in the wild and no public exploit code.","fix":"Upgrade text_helpers to 1.2.0 or later.","what":"CVE-2020-36624 is a medium-severity vulnerability in ahorner text-helpers, published on 22 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-36624 and fix it if it is affected.\n\nWhat it is: CVE-2020-36624 is a medium-severity vulnerability in ahorner text-helpers, published on 22 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-36624 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- text_helpers (RubyGems): affected from 1.1.0; fixed in 1.2.0\n- text_helpers (RubyGems): affected from 1.1.0; fixed in 1.2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-36624/ (Markdown: https://insights.sbomify.com/CVE-2020-36624/index.md)","id":"CVE-2020-36624","markdown":"https://insights.sbomify.com/CVE-2020-36624/index.md","name":"CVE-2020-36624","record":{"aliases":["GHSA-74hc-57m5-83ch"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby text-helpers library","requires_auth":"none","summary":"Attackers can exploit reverse tabnabbing via untrusted links in the text-helpers library, potentially hijacking user sessions or redirecting them to malicious sites.","user_interaction":"required","vuln_class":"open_redirect"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"texthelpers","vendor":"texthelpers_project"}],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-1022","name":"Use of Web Link to Untrusted Target with window.opener Access"}],"description":"A vulnerability was found in ahorner text-helpers up to 1.0.x. It has been declared as critical. This vulnerability affects unknown code of the file lib/text_helpers/translation.rb. The manipulation of the argument link leads to use of web link to untrusted target with window.opener access. The attack can be initiated remotely. Upgrading to version 1.1.0 is able to address this issue. The name of the patch is 184b60ded0e43c985788582aca2d1e746f9405a3. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-216520.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"ahorner text-helpers translation.rb reverse tabnabbing","id":"CVE-2020-36624","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"open_redirect","year":"2020"},"n_packages":2,"n_references":4,"next":{"headline":"destiny.gg chat main.go websocket.Upgrader cross-site request forgery","id":"CVE-2020-36625"},"packages":[{"ecosystem":"RubyGems","fixed":["1.2.0"],"introduced":["1.1.0"],"last_affected":[],"package":"text_helpers","purl":null,"source":"GHSA-74hc-57m5-83ch"},{"ecosystem":"RubyGems","fixed":["1.2.0"],"introduced":["1.1.0"],"last_affected":[],"package":"text_helpers","purl":"pkg:gem/text_helpers","source":"GHSA-74hc-57m5-83ch"}],"prev":{"headline":"Pengu index.js runApp cross-site request forgery","id":"CVE-2020-36623"},"products":["text-helpers"],"published":"2022-12-22","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["ahorner"]},"summary":"Attackers can exploit reverse tabnabbing via untrusted links in the text-helpers library, potentially hijacking user sessions or redirecting them to malicious sites.","url":"https://insights.sbomify.com/CVE-2020-36624/"}