# CVE-2020-36624: ahorner text-helpers translation.rb reverse tabnabbing

> Attackers can exploit reverse tabnabbing via untrusted links in the text-helpers library, potentially hijacking user sessions or redirecting them to malicious sites.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Dec 2022
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-74hc-57m5-83ch

## What is CVE-2020-36624?

CVE-2020-36624 is a medium-severity vulnerability in ahorner text-helpers, published on 22 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A vulnerability was found in ahorner text-helpers up to 1.0.x. It has been declared as critical. This vulnerability affects unknown code of the file lib/text_helpers/translation.rb. The manipulation of the argument link leads to use of web link to untrusted target with window.opener access. The attack can be initiated remotely. Upgrading to version 1.1.0 is able to address this issue. The name of the patch is 184b60ded0e43c985788582aca2d1e746f9405a3. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-216520.

Weakness: CWE-1022 (Use of Web Link to Untrusted Target with window.opener Access)

## Which versions are affected by CVE-2020-36624?

2 open source packages ship an affected version, including text_helpers. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `text_helpers` | RubyGems | From 1.1.0 | 1.2.0 |
| `text_helpers` | RubyGems | From 1.1.0 | 1.2.0 |

Products: Texthelpers Project Texthelpers.

## How do I fix CVE-2020-36624?

Upgrade text_helpers to 1.2.0 or later.

## Is CVE-2020-36624 being exploited?

There is no known exploitation of CVE-2020-36624 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-36624 and fix it if it is affected.

What it is: CVE-2020-36624 is a medium-severity vulnerability in ahorner text-helpers, published on 22 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-36624 in the wild and no public exploit code.

Affected packages and fixed versions:
- text_helpers (RubyGems): affected from 1.1.0; fixed in 1.2.0
- text_helpers (RubyGems): affected from 1.1.0; fixed in 1.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-36624/ (Markdown: https://insights.sbomify.com/CVE-2020-36624/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-36624
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-36624
- OSV: https://osv.dev/vulnerability/CVE-2020-36624

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-36624/
Summaries are generated and may contain mistakes; the official description above is the record.
