# CVE-2020-36629: SimbCo httpster server.coffee fs.realpathSync path traversal

> Attackers can exploit a path traversal vulnerability in the httpster library to read or modify arbitrary files on the server.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Dec 2022
- **Updated:** 14 Apr 2025
- **Also known as:** GHSA-p8j8-wxvp-h695

## What is CVE-2020-36629?

CVE-2020-36629 is a medium-severity path traversal vulnerability in SimbCo httpster, published on 25 Dec 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability classified as critical was found in SimbCo httpster. This vulnerability affects the function fs.realpathSync of the file src/server.coffee. The manipulation leads to path traversal. The exploit has been disclosed to the public and may be used. The name of the patch is d3055b3e30b40b65d30c5a06d6e053dffa7f35d0. It is recommended to apply a patch to fix this issue. The identifier of this vulnerability is VDB-216748.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2020-36629?

2 open source packages ship an affected version, including httpster. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `httpster` | npm | All versions | 1.1.0 |
| `httpster` | npm | All versions | 1.1.0 |

Products: Httpster Project Httpster.

## How do I fix CVE-2020-36629?

Upgrade httpster to 1.1.0 or later.

## Is CVE-2020-36629 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-36629 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-36629 and fix it if it is affected.

What it is: CVE-2020-36629 is a medium-severity path traversal vulnerability in SimbCo httpster, published on 25 Dec 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-36629 exists.

Affected packages and fixed versions:
- httpster (npm): affected all versions; fixed in 1.1.0
- httpster (npm): affected all versions; fixed in 1.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-36629/ (Markdown: https://insights.sbomify.com/CVE-2020-36629/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-36629
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-36629
- OSV: https://osv.dev/vulnerability/CVE-2020-36629

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-36629/
Summaries are generated and may contain mistakes; the official description above is the record.
