# CVE-2020-36634: Indeed Engineering util ViewExportedVariablesServlet.java appendTo cross site scripting

> Remote attackers can execute arbitrary scripts via cross-site scripting in the ViewExportedVariablesServlet component of the Indeed Engineering util library.

- **Severity:** Low 2.6 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 27 Dec 2022
- **Updated:** 19 Nov 2024
- **Also known as:** GHSA-jpmp-fq2w-x5v7

## What is CVE-2020-36634?

CVE-2020-36634 is a low-severity cross-site scripting vulnerability in Indeed Engineering util, published on 27 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A vulnerability classified as problematic has been found in Indeed Engineering util up to 1.0.33. Affected is the function visit/appendTo of the file varexport/src/main/java/com/indeed/util/varexport/servlet/ViewExportedVariablesServlet.java. The manipulation leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 1.0.34 is able to address this issue. The name of the patch is c0952a9db51a880e9544d9fac2a2218a6bfc9c63. It is recommended to upgrade the affected component. VDB-216882 is the identifier assigned to this vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-36634?

It affects 1 product.


Products: Indeed Util.

## How do I fix CVE-2020-36634?

No fix has been published for CVE-2020-36634 yet. Limit exposure of the affected software until one is available.

## Is CVE-2020-36634 being exploited?

There is no known exploitation of CVE-2020-36634 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-36634 and fix it if it is affected.

What it is: CVE-2020-36634 is a low-severity cross-site scripting vulnerability in Indeed Engineering util, published on 27 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-36634 in the wild and no public exploit code.

Affected product: Indeed Engineering util. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-36634/ (Markdown: https://insights.sbomify.com/CVE-2020-36634/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-36634
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-36634
- OSV: https://osv.dev/vulnerability/CVE-2020-36634

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-36634/
Summaries are generated and may contain mistakes; the official description above is the record.
