# CVE-2020-36641: gturri aXMLRPC ResponseParser.java ResponseParser xml external entity reference

> An attacker can exploit XML external entity references in the aXMLRPC library to read sensitive data or cause denial of service.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Jan 2023
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-g4r8-28fp-f255, UBUNTU-CVE-2020-36641

## What is CVE-2020-36641?

CVE-2020-36641 is a medium-severity vulnerability in gturri aXMLRPC, published on 5 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability classified as problematic was found in gturri aXMLRPC up to 1.12.0. This vulnerability affects the function ResponseParser of the file src/main/java/de/timroes/axmlrpc/ResponseParser.java. The manipulation leads to xml external entity reference. Upgrading to version 1.14.0 is able to address this issue. The patch is identified as 456752ebc1ef4c0db980cb5b01a0b3cd0a9e0bae. It is recommended to upgrade the affected component. VDB-217450 is the identifier assigned to this vulnerability.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2020-36641?

2 open source packages ship an affected version, including fr.turri:aXMLRPC. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fr.turri:aXMLRPC` | Maven | All versions | 1.12.1 |
| `fr.turri:aXMLRPC` | Maven | All versions | 1.12.1 |

Products: Gturri Axmlrpc.

## How do I fix CVE-2020-36641?

Upgrade fr.turri:aXMLRPC to 1.12.1 or later.

## Is CVE-2020-36641 being exploited?

There is no known exploitation of CVE-2020-36641 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-36641 and fix it if it is affected.

What it is: CVE-2020-36641 is a medium-severity vulnerability in gturri aXMLRPC, published on 5 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-36641 in the wild and no public exploit code.

Affected packages and fixed versions:
- fr.turri:aXMLRPC (Maven): affected all versions; fixed in 1.12.1
- fr.turri:aXMLRPC (Maven): affected all versions; fixed in 1.12.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-36641/ (Markdown: https://insights.sbomify.com/CVE-2020-36641/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-36641
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-36641
- OSV: https://osv.dev/vulnerability/CVE-2020-36641

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-36641/
Summaries are generated and may contain mistakes; the official description above is the record.
