# CVE-2020-36642: trampgeek jobe LanguageTask.php run_in_sandbox command injection


- **Severity:** Medium 5.5 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 6 Jan 2023
- **Updated:** 10 Apr 2025
- **Also known as:** GHSA-p576-j8jp-6qr7

## What is CVE-2020-36642?

CVE-2020-36642 is a medium-severity vulnerability in trampgeek jobe, published on 6 Jan 2023. 

### Official description

A vulnerability was found in trampgeek jobe up to 1.6.x and classified as critical. This issue affects the function run_in_sandbox of the file application/libraries/LanguageTask.php. The manipulation leads to command injection. Upgrading to version 1.7.0 is able to address this issue. The identifier of the patch is 8f43daf50c943b98eaf0c542da901a4a16e85b02. It is recommended to upgrade the affected component. The identifier VDB-217553 was assigned to this vulnerability.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2020-36642?

It affects 1 product.


Products: Jobe Project Jobe.

## How do I fix CVE-2020-36642?

No fix has been published for CVE-2020-36642 yet. Limit exposure of the affected software until one is available.

## Is CVE-2020-36642 being exploited?

There is no known exploitation of CVE-2020-36642 in the wild and no public exploit code.

## Other vulnerabilities in trampgeek jobe

- [CVE-2021-4297](https://insights.sbomify.com/CVE-2021-4297/): trampgeek jobe Restapi.php runs_post Privilege Escalation (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-36642 and fix it if it is affected.

What it is: CVE-2020-36642 is a medium-severity vulnerability in trampgeek jobe, published on 6 Jan 2023. 
Exploitation: There is no known exploitation of CVE-2020-36642 in the wild and no public exploit code.

Affected product: trampgeek jobe. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-36642/ (Markdown: https://insights.sbomify.com/CVE-2020-36642/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-36642
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-36642
- OSV: https://osv.dev/vulnerability/CVE-2020-36642

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-36642/
Summaries are generated and may contain mistakes; the official description above is the record.
