{"answers":{"affected":"2 open source packages ship an affected version, including inline_svg. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-36644 in the wild and no public exploit code.","fix":"Upgrade inline_svg to 1.7.2 or later.","what":"CVE-2020-36644 is a low-severity cross-site scripting vulnerability in jamesmartin Inline SVG, published on 7 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-36644 and fix it if it is affected.\n\nWhat it is: CVE-2020-36644 is a low-severity cross-site scripting vulnerability in jamesmartin Inline SVG, published on 7 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-36644 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- inline_svg (RubyGems): affected all versions; fixed in 1.7.2\n- inline_svg (RubyGems): affected all versions; fixed in 1.7.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-36644/ (Markdown: https://insights.sbomify.com/CVE-2020-36644/index.md)","id":"CVE-2020-36644","markdown":"https://insights.sbomify.com/CVE-2020-36644/index.md","name":"CVE-2020-36644","record":{"aliases":["GHSA-p33q-4h4m-j994"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby Inline SVG library","requires_auth":"low_privilege","summary":"Attackers can inject malicious scripts via the filename argument in the Inline SVG Ruby library, potentially executing code in user browsers.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"inline_svg","vendor":"inline_svg_project"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability has been found in jamesmartin Inline SVG up to 1.7.1 and classified as problematic. Affected by this vulnerability is an unknown functionality of the file lib/inline_svg/action_view/helpers.rb of the component URL Parameter Handler. The manipulation of the argument filename leads to cross site scripting. The attack can be launched remotely. Upgrading to version 1.7.2 is able to address this issue. The identifier of the patch is f5363b351508486021f99e083c92068cf2943621. It is recommended to upgrade the affected component. The identifier VDB-217597 was assigned to this vulnerability.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"jamesmartin Inline SVG URL Parameter helpers.rb cross site scripting","id":"CVE-2020-36644","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"xss","year":"2020"},"n_packages":2,"n_references":5,"next":{"headline":"square squalor sql injection","id":"CVE-2020-36645"},"packages":[{"ecosystem":"RubyGems","fixed":["1.7.2"],"introduced":["0"],"last_affected":[],"package":"inline_svg","purl":null,"source":"GHSA-p33q-4h4m-j994"},{"ecosystem":"RubyGems","fixed":["1.7.2"],"introduced":["0"],"last_affected":[],"package":"inline_svg","purl":"pkg:gem/inline_svg","source":"GHSA-p33q-4h4m-j994"}],"prev":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2020-36643"},"products":["Inline SVG"],"published":"2023-01-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-28","vendors":["jamesmartin"]},"summary":"Attackers can inject malicious scripts via the filename argument in the Inline SVG Ruby library, potentially executing code in user browsers.","url":"https://insights.sbomify.com/CVE-2020-36644/"}