# CVE-2020-36644: jamesmartin Inline SVG URL Parameter helpers.rb cross site scripting

> Attackers can inject malicious scripts via the filename argument in the Inline SVG Ruby library, potentially executing code in user browsers.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Jan 2023
- **Updated:** 28 May 2025
- **Also known as:** GHSA-p33q-4h4m-j994

## What is CVE-2020-36644?

CVE-2020-36644 is a low-severity cross-site scripting vulnerability in jamesmartin Inline SVG, published on 7 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A vulnerability has been found in jamesmartin Inline SVG up to 1.7.1 and classified as problematic. Affected by this vulnerability is an unknown functionality of the file lib/inline_svg/action_view/helpers.rb of the component URL Parameter Handler. The manipulation of the argument filename leads to cross site scripting. The attack can be launched remotely. Upgrading to version 1.7.2 is able to address this issue. The identifier of the patch is f5363b351508486021f99e083c92068cf2943621. It is recommended to upgrade the affected component. The identifier VDB-217597 was assigned to this vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-36644?

2 open source packages ship an affected version, including inline_svg. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `inline_svg` | RubyGems | All versions | 1.7.2 |
| `inline_svg` | RubyGems | All versions | 1.7.2 |

Products: Inline Svg Project Inline Svg.

## How do I fix CVE-2020-36644?

Upgrade inline_svg to 1.7.2 or later.

## Is CVE-2020-36644 being exploited?

There is no known exploitation of CVE-2020-36644 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-36644 and fix it if it is affected.

What it is: CVE-2020-36644 is a low-severity cross-site scripting vulnerability in jamesmartin Inline SVG, published on 7 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-36644 in the wild and no public exploit code.

Affected packages and fixed versions:
- inline_svg (RubyGems): affected all versions; fixed in 1.7.2
- inline_svg (RubyGems): affected all versions; fixed in 1.7.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-36644/ (Markdown: https://insights.sbomify.com/CVE-2020-36644/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-36644
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-36644
- OSV: https://osv.dev/vulnerability/CVE-2020-36644

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-36644/
Summaries are generated and may contain mistakes; the official description above is the record.
