# CVE-2020-36646: MediaArea ZenLib Ztring.cpp Date_From_Seconds_1970_Local unknown vulnerability


- **Severity:** Low 3.5 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 7 Jan 2023
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2020-36646, DLA-3290-1, GHSA-2mm8-pf66-mch4, MGASA-2023-0046, UBUNTU-CVE-2020-36646, USN-6048-1

## What is CVE-2020-36646?

CVE-2020-36646 is a low-severity vulnerability in MediaArea ZenLib, published on 7 Jan 2023. 

### Official description

A vulnerability classified as problematic has been found in MediaArea ZenLib up to 0.4.38. This affects the function Ztring::Date_From_Seconds_1970_Local of the file Source/ZenLib/Ztring.cpp. The manipulation of the argument Value leads to unchecked return value to null pointer dereference. Upgrading to version 0.4.39 is able to address this issue. The identifier of the patch is 6475fcccd37c9cf17e0cfe263b5fe0e2e47a8408. It is recommended to upgrade the affected component. The identifier VDB-217629 was assigned to this vulnerability.

Weakness: CWE-476 (NULL Pointer Dereference), CWE-690 (Unchecked Return Value to NULL Pointer Dereference)

## Which versions are affected by CVE-2020-36646?

It affects 1 product.


Products: Mediaarea Zenlib.

## How do I fix CVE-2020-36646?

Upgrade to a fixed version.

## Is CVE-2020-36646 being exploited?

There is no known exploitation of CVE-2020-36646 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-36646 and fix it if it is affected.

What it is: CVE-2020-36646 is a low-severity vulnerability in MediaArea ZenLib, published on 7 Jan 2023. 
Exploitation: There is no known exploitation of CVE-2020-36646 in the wild and no public exploit code.

Affected product: MediaArea ZenLib. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-36646/ (Markdown: https://insights.sbomify.com/CVE-2020-36646/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-36646
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-36646
- OSV: https://osv.dev/vulnerability/CVE-2020-36646

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-36646/
Summaries are generated and may contain mistakes; the official description above is the record.
