# CVE-2020-36649: mholt PapaParse papaparse.js redos


- **Severity:** Low 3.5 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 11 Jan 2023
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2020-36649, GHSA-qvjc-g5vr-mfgr, UBUNTU-CVE-2020-36649

## What is CVE-2020-36649?

CVE-2020-36649 is a low-severity vulnerability in mholt PapaParse, published on 11 Jan 2023. 

### Official description

A vulnerability was found in mholt PapaParse up to 5.1.x. It has been classified as problematic. Affected is an unknown function of the file papaparse.js. The manipulation leads to inefficient regular expression complexity. Upgrading to version 5.2.0 is able to address this issue. The name of the patch is 235a12758cd77266d2e98fd715f53536b34ad621. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-218004.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2020-36649?

2 open source packages ship an affected version, including papaparse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `papaparse` | npm | All versions | 5.2.0 |
| `papaparse` | npm | All versions | 5.2.0 |

Products: Papaparse Papaparse.

## How do I fix CVE-2020-36649?

Upgrade papaparse to 5.2.0 or later.

## Is CVE-2020-36649 being exploited?

There is no known exploitation of CVE-2020-36649 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-36649 and fix it if it is affected.

What it is: CVE-2020-36649 is a low-severity vulnerability in mholt PapaParse, published on 11 Jan 2023. 
Exploitation: There is no known exploitation of CVE-2020-36649 in the wild and no public exploit code.

Affected packages and fixed versions:
- papaparse (npm): affected all versions; fixed in 5.2.0
- papaparse (npm): affected all versions; fixed in 5.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-36649/ (Markdown: https://insights.sbomify.com/CVE-2020-36649/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-36649
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-36649
- OSV: https://osv.dev/vulnerability/CVE-2020-36649

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-36649/
Summaries are generated and may contain mistakes; the official description above is the record.
