# CVE-2020-36650: IonicaBizau node-gry command injection


- **Severity:** Medium 5.5 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 11 Jan 2023
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-w5mw-f2hq-5fw8

## What is CVE-2020-36650?

CVE-2020-36650 is a medium-severity vulnerability in IonicaBizau node-gry, published on 11 Jan 2023. 

### Official description

A vulnerability, which was classified as critical, was found in IonicaBizau node-gry up to 5.x. This affects an unknown part. The manipulation leads to command injection. Upgrading to version 6.0.0 is able to address this issue. The patch is named 5108446c1e23960d65e8b973f1d9486f9f9dbd6c. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-218019.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2020-36650?

2 open source packages ship an affected version, including gry. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gry` | npm | All versions | 6.0.0 |
| `gry` | npm | All versions | 6.0.0 |

Products: Gry Project Gry.

## How do I fix CVE-2020-36650?

Upgrade gry to 6.0.0 or later.

## Is CVE-2020-36650 being exploited?

There is no known exploitation of CVE-2020-36650 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-36650 and fix it if it is affected.

What it is: CVE-2020-36650 is a medium-severity vulnerability in IonicaBizau node-gry, published on 11 Jan 2023. 
Exploitation: There is no known exploitation of CVE-2020-36650 in the wild and no public exploit code.

Affected packages and fixed versions:
- gry (npm): affected all versions; fixed in 6.0.0
- gry (npm): affected all versions; fixed in 6.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-36650/ (Markdown: https://insights.sbomify.com/CVE-2020-36650/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-36650
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-36650
- OSV: https://osv.dev/vulnerability/CVE-2020-36650

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-36650/
Summaries are generated and may contain mistakes; the official description above is the record.
