{"answers":{"affected":"2 open source packages ship an affected version, including web-node-server. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-36651 exists.","fix":"Upgrade web-node-server to 0.0.11 or later.","what":"CVE-2020-36651 is a medium-severity path traversal vulnerability in youngerheart nodeserver, published on 18 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-36651 and fix it if it is affected.\n\nWhat it is: CVE-2020-36651 is a medium-severity path traversal vulnerability in youngerheart nodeserver, published on 18 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-36651 exists.\n\nAffected packages and fixed versions:\n- web-node-server (npm): affected all versions; fixed in 0.0.11\n- web-node-server (npm): affected all versions; fixed in 0.0.11\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-36651/ (Markdown: https://insights.sbomify.com/CVE-2020-36651/index.md)","id":"CVE-2020-36651","markdown":"https://insights.sbomify.com/CVE-2020-36651/index.md","name":"CVE-2020-36651","record":{"aliases":["GHSA-3fwq-qv5v-2wxf"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Node.js server","requires_auth":"low_privilege","summary":"An attacker can exploit a path traversal vulnerability in youngerheart nodeserver to read arbitrary files from the server.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"nodeserver","vendor":"nodeserver_project"}],"cvss":{"score":5.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"A vulnerability has been found in youngerheart nodeserver and classified as critical. Affected by this vulnerability is an unknown functionality of the file nodeserver.js. The manipulation leads to path traversal. The identifier of the patch is c4c0f0138ab5afbac58e03915d446680421bde28. It is recommended to apply a patch to fix this issue. The identifier VDB-218461 was assigned to this vulnerability.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"youngerheart nodeserver nodeserver.js path traversal","id":"CVE-2020-36651","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"path_traversal","year":"2020"},"n_packages":2,"n_references":4,"next":{"headline":"Misconfiguration in Hitachi Automation Director","id":"CVE-2020-36652"},"packages":[{"ecosystem":"npm","fixed":["0.0.11"],"introduced":["0"],"last_affected":[],"package":"web-node-server","purl":null,"source":"GHSA-3fwq-qv5v-2wxf"},{"ecosystem":"npm","fixed":["0.0.11"],"introduced":["0"],"last_affected":[],"package":"web-node-server","purl":"pkg:npm/web-node-server","source":"GHSA-3fwq-qv5v-2wxf"}],"prev":{"headline":"IonicaBizau node-gry command injection","id":"CVE-2020-36650"},"products":["nodeserver"],"published":"2023-01-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-11-25","vendors":["youngerheart"]},"summary":"An attacker can exploit a path traversal vulnerability in youngerheart nodeserver to read arbitrary files from the server.","url":"https://insights.sbomify.com/CVE-2020-36651/"}