# CVE-2020-36651: youngerheart nodeserver nodeserver.js path traversal

> An attacker can exploit a path traversal vulnerability in youngerheart nodeserver to read arbitrary files from the server.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Jan 2023
- **Updated:** 25 Nov 2024
- **Also known as:** GHSA-3fwq-qv5v-2wxf

## What is CVE-2020-36651?

CVE-2020-36651 is a medium-severity path traversal vulnerability in youngerheart nodeserver, published on 18 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability has been found in youngerheart nodeserver and classified as critical. Affected by this vulnerability is an unknown functionality of the file nodeserver.js. The manipulation leads to path traversal. The identifier of the patch is c4c0f0138ab5afbac58e03915d446680421bde28. It is recommended to apply a patch to fix this issue. The identifier VDB-218461 was assigned to this vulnerability.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2020-36651?

2 open source packages ship an affected version, including web-node-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `web-node-server` | npm | All versions | 0.0.11 |
| `web-node-server` | npm | All versions | 0.0.11 |

Products: Nodeserver Project Nodeserver.

## How do I fix CVE-2020-36651?

Upgrade web-node-server to 0.0.11 or later.

## Is CVE-2020-36651 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-36651 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-36651 and fix it if it is affected.

What it is: CVE-2020-36651 is a medium-severity path traversal vulnerability in youngerheart nodeserver, published on 18 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-36651 exists.

Affected packages and fixed versions:
- web-node-server (npm): affected all versions; fixed in 0.0.11
- web-node-server (npm): affected all versions; fixed in 0.0.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-36651/ (Markdown: https://insights.sbomify.com/CVE-2020-36651/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-36651
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-36651
- OSV: https://osv.dev/vulnerability/CVE-2020-36651

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-36651/
Summaries are generated and may contain mistakes; the official description above is the record.
