# CVE-2020-36655: Command injection in yiisoft/yii2-gii

> Remote attackers can execute arbitrary PHP code via the Gii module's messageCategory field, requiring the Gii module to be enabled.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Jan 2023
- **Updated:** 2 Apr 2025
- **Also known as:** GHSA-3mpg-q26j-83j5

## What is CVE-2020-36655?

CVE-2020-36655 is a high-severity code injection vulnerability in n/a, published on 21 Jan 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Yii Yii2 Gii before 2.2.2 allows remote attackers to execute arbitrary code via the Generator.php messageCategory field. The attacker can embed arbitrary PHP code into the model file.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2020-36655?

2 open source packages ship an affected version, including yiisoft/yii2-gii. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yiisoft/yii2-gii` | Packagist | All versions | 2.2.2 |
| `yiisoft/yii2-gii` | Packagist | All versions | 2.2.2 |

Products: Yiiframework Gii.

## How do I fix CVE-2020-36655?

Upgrade yiisoft/yii2-gii to 2.2.2 or later.

## Is CVE-2020-36655 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-36655 exists.

## Other vulnerabilities in n/a

- [CVE-2022-34297](https://insights.sbomify.com/CVE-2022-34297/): Yii2 Gii Cross-site Scripting vulnerability (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-36655 and fix it if it is affected.

What it is: CVE-2020-36655 is a high-severity code injection vulnerability in n/a, published on 21 Jan 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-36655 exists.

Affected packages and fixed versions:
- yiisoft/yii2-gii (Packagist): affected all versions; fixed in 2.2.2
- yiisoft/yii2-gii (Packagist): affected all versions; fixed in 2.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-36655/ (Markdown: https://insights.sbomify.com/CVE-2020-36655/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-36655
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-36655
- OSV: https://osv.dev/vulnerability/CVE-2020-36655

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-36655/
Summaries are generated and may contain mistakes; the official description above is the record.
