CVE-2020-36660 paxswill EVE Ship Replacement Program User Information api.py information disclosure

Medium 4.3 Published Updated

Remote attackers can access sensitive user information via the User Information Handler in the EVE Ship Replacement Program.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2020-36660?

CVE-2020-36660 is a medium-severity vulnerability in paxswill EVE Ship Replacement Program, published on 6 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A vulnerability was found in paxswill EVE Ship Replacement Program 0.12.11. It has been rated as problematic. This issue affects some unknown processing of the file src/evesrp/views/api.py of the component User Information Handler. The manipulation leads to information disclosure. The attack may be initiated remotely. Upgrading to version 0.12.12 is able to address this issue. The patch is named 9e03f68e46e85ca9c9694a6971859b3ee66f0240. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-220211.

Weakness: CWE-200

Which versions are affected by CVE-2020-36660?

3 open source packages ship an affected version, including eve-srp and EVE-SRP. It affects 1 product.

PackageAffectedFixed in
eve-srp PyPIAll versionsNone
eve-srp PyPIAll versions0.12.12
EVE-SRP PyPIAll versions0.12.12

Products include Eve Ship Replacement Program Project Eve Ship Replacement Program.

How do I fix CVE-2020-36660?

Upgrade eve-srp to 0.12.12 or later.

Is CVE-2020-36660 being exploited?

There is no known exploitation of CVE-2020-36660 in the wild and no public exploit code.

Sources

Also known as GHSA-fxqx-xgqq-gf42, PYSEC-2023-208.

Is CVE-2020-36660 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free