{"answers":{"affected":"3 open source packages ship an affected version, including eve-srp and EVE-SRP. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-36660 in the wild and no public exploit code.","fix":"Upgrade eve-srp to 0.12.12 or later.","what":"CVE-2020-36660 is a medium-severity vulnerability in paxswill EVE Ship Replacement Program, published on 6 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-36660 and fix it if it is affected.\n\nWhat it is: CVE-2020-36660 is a medium-severity vulnerability in paxswill EVE Ship Replacement Program, published on 6 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-36660 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- eve-srp (PyPI): affected all versions; no fix listed\n- eve-srp (PyPI): affected all versions; fixed in 0.12.12\n- EVE-SRP (PyPI): affected all versions; fixed in 0.12.12\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-36660/ (Markdown: https://insights.sbomify.com/CVE-2020-36660/index.md)","id":"CVE-2020-36660","markdown":"https://insights.sbomify.com/CVE-2020-36660/index.md","name":"CVE-2020-36660","record":{"aliases":["GHSA-fxqx-xgqq-gf42","PYSEC-2023-208"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"EVE Ship Replacement Program","requires_auth":"low_privilege","summary":"Remote attackers can access sensitive user information via the User Information Handler in the EVE Ship Replacement Program.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"eve_ship_replacement_program","vendor":"eve_ship_replacement_program_project"}],"cvss":{"score":4.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"A vulnerability was found in paxswill EVE Ship Replacement Program 0.12.11. It has been rated as problematic. This issue affects some unknown processing of the file src/evesrp/views/api.py of the component User Information Handler. The manipulation leads to information disclosure. The attack may be initiated remotely. Upgrading to version 0.12.12 is able to address this issue. The patch is named 9e03f68e46e85ca9c9694a6971859b3ee66f0240. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-220211.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"paxswill EVE Ship Replacement Program User Information api.py information disclosure","id":"CVE-2020-36660","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"information_disclosure","year":"2020"},"n_packages":3,"n_references":4,"next":{"headline":"Kong lua-multipart multipart.lua is_header redos","id":"CVE-2020-36661"},"packages":[{"ecosystem":"PyPI","fixed":["0.12.12"],"introduced":["0"],"last_affected":[],"package":"EVE-SRP","purl":null,"source":"GHSA-fxqx-xgqq-gf42"},{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":[],"package":"eve-srp","purl":"pkg:pypi/eve-srp","source":"PYSEC-2023-208"},{"ecosystem":"PyPI","fixed":["0.12.12"],"introduced":["0"],"last_affected":[],"package":"eve-srp","purl":"pkg:pypi/eve-srp","source":"GHSA-fxqx-xgqq-gf42"}],"prev":{"headline":"Security feature bypass in n/a","id":"CVE-2020-36659"},"products":["EVE Ship Replacement Program"],"published":"2023-02-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-11-25","vendors":["paxswill"]},"summary":"Remote attackers can access sensitive user information via the User Information Handler in the EVE Ship Replacement Program.","url":"https://insights.sbomify.com/CVE-2020-36660/"}