# CVE-2020-36660: paxswill EVE Ship Replacement Program User Information api.py information disclosure

> Remote attackers can access sensitive user information via the User Information Handler in the EVE Ship Replacement Program.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Feb 2023
- **Updated:** 25 Nov 2024
- **Also known as:** GHSA-fxqx-xgqq-gf42, PYSEC-2023-208

## What is CVE-2020-36660?

CVE-2020-36660 is a medium-severity vulnerability in paxswill EVE Ship Replacement Program, published on 6 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability was found in paxswill EVE Ship Replacement Program 0.12.11. It has been rated as problematic. This issue affects some unknown processing of the file src/evesrp/views/api.py of the component User Information Handler. The manipulation leads to information disclosure. The attack may be initiated remotely. Upgrading to version 0.12.12 is able to address this issue. The patch is named 9e03f68e46e85ca9c9694a6971859b3ee66f0240. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-220211.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2020-36660?

3 open source packages ship an affected version, including eve-srp and EVE-SRP. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `eve-srp` | PyPI | All versions | None |
| `eve-srp` | PyPI | All versions | 0.12.12 |
| `EVE-SRP` | PyPI | All versions | 0.12.12 |

Products: Eve Ship Replacement Program Project Eve Ship Replacement Program.

## How do I fix CVE-2020-36660?

Upgrade eve-srp to 0.12.12 or later.

## Is CVE-2020-36660 being exploited?

There is no known exploitation of CVE-2020-36660 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-36660 and fix it if it is affected.

What it is: CVE-2020-36660 is a medium-severity vulnerability in paxswill EVE Ship Replacement Program, published on 6 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-36660 in the wild and no public exploit code.

Affected packages and fixed versions:
- eve-srp (PyPI): affected all versions; no fix listed
- eve-srp (PyPI): affected all versions; fixed in 0.12.12
- EVE-SRP (PyPI): affected all versions; fixed in 0.12.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-36660/ (Markdown: https://insights.sbomify.com/CVE-2020-36660/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-36660
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-36660
- OSV: https://osv.dev/vulnerability/CVE-2020-36660

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-36660/
Summaries are generated and may contain mistakes; the official description above is the record.
