{"answers":{"affected":"2 open source packages ship an affected version, including crypto-js. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-36732 in the wild and no public exploit code.","fix":"Upgrade crypto-js to 3.2.1 or later.","what":"CVE-2020-36732 is a medium-severity vulnerability in n/a, published on 12 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-36732 and fix it if it is affected.\n\nWhat it is: CVE-2020-36732 is a medium-severity vulnerability in n/a, published on 12 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-36732 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- crypto-js (npm): affected from 3.2.0; fixed in 3.2.1\n- crypto-js (npm): affected from 3.2.0; fixed in 3.2.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-36732/ (Markdown: https://insights.sbomify.com/CVE-2020-36732/index.md)","id":"CVE-2020-36732","markdown":"https://insights.sbomify.com/CVE-2020-36732/index.md","name":"CVE-2020-36732","record":{"aliases":["DEBIAN-CVE-2020-36732","GHSA-3w3w-pxmm-2w2j"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js crypto library","requires_auth":"none","summary":"The crypto-js library generates predictable random numbers, potentially allowing attackers to bypass security controls relying on randomness.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"crypto-js","vendor":"crypto-js_project"}],"cvss":{"score":5.3,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-330","name":"Use of Insufficiently Random Values"},{"id":"CWE-331","name":"Insufficient Entropy"}],"description":"The crypto-js package before 3.2.1 for Node.js generates random numbers by concatenating the string \"0.\" with an integer, which makes the output more predictable than necessary.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"crypto-js uses insecure random numbers","id":"CVE-2020-36732","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"weak_cryptography","year":"2020"},"n_packages":2,"n_references":6,"next":{"headline":"Cross-site request forgery in ERP: Complete HR, Accounting \u0026 CRM Suite with WooCommerce CRM Support","id":"CVE-2020-36735"},"packages":[{"ecosystem":"npm","fixed":["3.2.1"],"introduced":["3.2.0"],"last_affected":[],"package":"crypto-js","purl":null,"source":"GHSA-3w3w-pxmm-2w2j"},{"ecosystem":"npm","fixed":["3.2.1"],"introduced":["3.2.0"],"last_affected":[],"package":"crypto-js","purl":"pkg:npm/crypto-js","source":"GHSA-3w3w-pxmm-2w2j"}],"prev":{"headline":"Flexible Checkout Fields for WooCommerce \u003c= 2.3.1 - Unauthenticated Arbitrary Plugin Settings Update","id":"CVE-2020-36731"},"products":["n/a"],"published":"2023-06-12","related":[{"cvss_score":9.1,"headline":"crypto-js PBKDF2 1,000 times weaker than specified in 1993 and 1.3M times weaker than current standard","id":"CVE-2023-46233","kev_date_added":null,"published":"2023-10-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-01-06","vendors":["n/a"]},"summary":"The crypto-js library generates predictable random numbers, potentially allowing attackers to bypass security controls relying on randomness.","url":"https://insights.sbomify.com/CVE-2020-36732/"}