# CVE-2020-36732: crypto-js uses insecure random numbers

> The crypto-js library generates predictable random numbers, potentially allowing attackers to bypass security controls relying on randomness.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jun 2023
- **Updated:** 6 Jan 2025
- **Also known as:** DEBIAN-CVE-2020-36732, GHSA-3w3w-pxmm-2w2j

## What is CVE-2020-36732?

CVE-2020-36732 is a medium-severity vulnerability in n/a, published on 12 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The crypto-js package before 3.2.1 for Node.js generates random numbers by concatenating the string "0." with an integer, which makes the output more predictable than necessary.

Weakness: CWE-330 (Use of Insufficiently Random Values), CWE-331 (Insufficient Entropy)

## Which versions are affected by CVE-2020-36732?

2 open source packages ship an affected version, including crypto-js. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `crypto-js` | npm | From 3.2.0 | 3.2.1 |
| `crypto-js` | npm | From 3.2.0 | 3.2.1 |

Products: Crypto-Js Project Crypto-Js.

## How do I fix CVE-2020-36732?

Upgrade crypto-js to 3.2.1 or later.

## Is CVE-2020-36732 being exploited?

There is no known exploitation of CVE-2020-36732 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-46233](https://insights.sbomify.com/CVE-2023-46233/): crypto-js PBKDF2 1,000 times weaker than specified in 1993 and 1.3M times weaker than current standard (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-36732 and fix it if it is affected.

What it is: CVE-2020-36732 is a medium-severity vulnerability in n/a, published on 12 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-36732 in the wild and no public exploit code.

Affected packages and fixed versions:
- crypto-js (npm): affected from 3.2.0; fixed in 3.2.1
- crypto-js (npm): affected from 3.2.0; fixed in 3.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-36732/ (Markdown: https://insights.sbomify.com/CVE-2020-36732/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-36732
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-36732
- OSV: https://osv.dev/vulnerability/CVE-2020-36732

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-36732/
Summaries are generated and may contain mistakes; the official description above is the record.
