{"answers":{"affected":"2 open source packages ship an affected version, including urlregex. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-36830 exists.","fix":"Upgrade urlregex to 0.5.1 or later.","what":"CVE-2020-36830 is a medium-severity denial of service vulnerability in nescalante urlregex, published on 2 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-36830 and fix it if it is affected.\n\nWhat it is: CVE-2020-36830 is a medium-severity denial of service vulnerability in nescalante urlregex, published on 2 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-36830 exists.\n\nAffected packages and fixed versions:\n- urlregex (npm): affected all versions; fixed in 0.5.1\n- urlregex (npm): affected all versions; fixed in 0.5.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-36830/ (Markdown: https://insights.sbomify.com/CVE-2020-36830/index.md)","id":"CVE-2020-36830","markdown":"https://insights.sbomify.com/CVE-2020-36830/index.md","name":"CVE-2020-36830","record":{"aliases":["GHSA-rw72-v6c7-hf9r"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"npm urlregex library","requires_auth":"low_privilege","summary":"Remote attackers can cause denial of service via inefficient regular expression complexity in the urlregex library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"urlregex","vendor":"nescalante"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"}],"description":"A vulnerability was found in nescalante urlregex up to 0.5.0 and classified as problematic. This issue affects some unknown processing of the file index.js of the component Backtracking. The manipulation leads to inefficient regular expression complexity. The attack may be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 0.5.1 is able to address this issue. The identifier of the patch is e5a085afe6abfaea1d1a78f54c45af9ef43ca1f9. It is recommended to upgrade the affected component.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"nescalante urlregex Backtracking index.js redos","id":"CVE-2020-36830","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2020"},"n_packages":2,"n_references":5,"next":{"headline":"NextScripts: Social Networks Auto-Poster \u003c= 4.3.17 - Missing Authorization","id":"CVE-2020-36831"},"packages":[{"ecosystem":"npm","fixed":["0.5.1"],"introduced":["0"],"last_affected":[],"package":"urlregex","purl":null,"source":"GHSA-rw72-v6c7-hf9r"},{"ecosystem":"npm","fixed":["0.5.1"],"introduced":["0"],"last_affected":[],"package":"urlregex","purl":"pkg:npm/urlregex","source":"GHSA-rw72-v6c7-hf9r"}],"prev":{"headline":"Information disclosure in n/a","id":"CVE-2020-36829"},"products":["urlregex"],"published":"2024-09-02","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-09-03","vendors":["nescalante"]},"summary":"Remote attackers can cause denial of service via inefficient regular expression complexity in the urlregex library.","url":"https://insights.sbomify.com/CVE-2020-36830/"}